Take the 2-minute tour ×
Electrical Engineering Stack Exchange is a question and answer site for electronics and electrical engineering professionals, students, and enthusiasts. It's 100% free, no registration required.

I'm making a water level indicator using an 89C51 for which I need 5 V input voltage. I used a 230 V to 12 V step down transformer and a regulator to get 5 V.

I got the 5 V but then the transformer started giving an output of 4.4 V instead of 12 V.

Can you please suggest the possible causes for this problem?

Power supply schematic:

share|improve this question
1  
Does it get hot? - If so you have probably connected something wrongly. || If you disconnect your circuitry does the voltage go back o 12 volts? If not th transformer is dead or your house wiring is faulty. If it does go back to 12V thn your circuit is wrong or your load is too heavy fo the circuit overall. –  Russell McMahon Oct 27 '11 at 17:21
    
yes it gets very hot...but even after disconnecting its not giving 12 V.if its dead then can you please suggest the possible cause? –  monika Oct 27 '11 at 17:32

2 Answers 2

How are you measuring this 4.4V output? Keep in mind that the transformer output will be AC, so your voltmeter needs to be set to AC to read the voltage properly.

A transformer rated for "12V" out should put that out at its maximum rated output current. That means it probably puts out more when unloaded. For some transformers, that could be significantly more, like up to 50% more.

Keep in mind that 12V AC will result in a higher rectified DC voltage. This is because the 12V spec is RMS. For a sine wave, such as your power voltage, the peaks will be sqrt(2) times higher than the RMS level. The peaks will be 17V for the case of 12V RMS. If this 12V transformer secondary is followed by a full wave bridge to make DC, then about 1.4V will be lost in the diodes. That leaves about 15.6V DC. Again, it may be somewhat higher when unloaded. 20V DC with no current drawn wouldn't be too surprising.

With 15-20V into the 5V regulator and 5V out, the regulator is dropping 10-15V. This times the current draw of the circuit will be burned up as heat in the regulator. For example, if the circuit draws 100mA, then then up to 15V * 100mA = 1.5W could go to heating the regulator. That is enough for a free standing TO-220 to possibly get hot enough for the regulator to shut itself down. This will happen at temperatures that will burn your finger. If you can hold onto the regulator for a few seconds without hurting yourself, then overheating of the regulator is not the problem.

So, here are some things you need to do so this question can be answered more than above:

  1. Show the schematic.

  2. Measure the output of the transformer with nothing connected with a AC voltmeter.

  3. Measure the output of the transformer with the circuit connected with a AC voltmeter.

  4. Measure the raw DC after the diodes witha the voltmeter set to DC.

  5. Measure the output of the regulator with a DC voltmeter.

  6. Report all these measurements here.

Added after power supply schematic available:

That takes care of #1, still waiting for #2-6.

Some observations from the schematic:

  1. 1N4007 is a strange choice for the diodes. They should work, but this can be done with 1N4001. You don't need the very high voltage rating of the 1N4007.

  2. You should have ceramic caps immediately accross the input and output of the regulator. 100nF to 1µF is good enough. These are to provide low impedance at high frequencies, which your electrolytics do not. Without these caps the 7805 could oscillate. In fact, that is one reason you could be measuring 4.4V on its output instead of 5V.

  3. 12V secondary is quite high if you just want to linearly regulate down to 5V. You're going to burn up most of the power in heat. That by itself may not be a problem, but dealing with the heat will be. A 6V or so secondary would be significantly more efficient and allow for higher current before the 7805 shuts down due to getting too hot.

share|improve this answer

As Olin says you need to make sure you are measuring the transformer unloaded (make sure nothing at all is attached) secondary voltage correctly, using a multimeter set to AC.

If the transformer still reads 4.4V with no load, then it sounds like it's dead. Check thoroughly for any dry joints/partial shorts that may be causing the problem.

The circuit you linked to looks like it could easily draw 100mA or so, maybe more. The transformer needs to be rated adequately in order to supply the current without problems. Some transformers are inherently short circuit proof, others are not and some may have fuses/overcurrent protection built in.
Did you have the complete circuit attached or just the 7805 power stage?

As well as the info Olin asked for, what is the transformers secondary current/power rating? A part number or datasheet would useful.

share|improve this answer

protected by Dave Tweed Jun 28 at 11:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.