0
\$\begingroup\$

I recently bought a LM2577 based boost converter board from dfrobots.com such as the one below.

LM2577 based boost converter board

I'm trying to use it to generate a stable 5v from a 3.7v 2100mAh Li-Po battery. The Li-Po voltage was now at 4v when I wired up the circuit. I connected it to power an android mini-PC (mk808/802 type, RK3188 based). The mini-PC worked for 15-20 minutes and suddenly shut-down, even the boost converter shut-down. It happened everytime I tried, sometimes within a few seconds.

The reason of shutdown was that it was getting ~0.6v at its \$V_{in}\$ pin which is weird since there is a Li-Po battery at 4v already connected to it, connections are firm, contacts are also good so it's not a connection/contact issue. It's not even a battery issue, I tried it with various batteries, same outcome. I use a standard micro-USB cable to power it, I just cut the cable and connected power and ground wires of USB cable to the same on the bost-converter board.

I just don't get what the reason for this ghostly 0.6V is? I highly doubt it might be due to some capacitor or the LM2577 itself, I don't know what it is, but it's totally annoying.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Could you add a link to some schematics of your setup? That would help us troubleshoot it for you. I can then add it inline to the question if you don't have enough rep to do so. \$\endgroup\$ – Ricardo Feb 25 '14 at 12:54
  • 1
    \$\begingroup\$ dfrobot.com/index.php?route=product/… The above is the link to the breakout board I use, I just connect batteries to V_in and GND, and connect 5v and GND from USB Cable wire to V_out and GND respectively \$\endgroup\$ – Imran Munshi Feb 26 '14 at 4:28
  • \$\begingroup\$ Ever heard of that saying that "A picture is worth a thousand words"? Well, it would in this case. I suppose that your question would get a bit more attention if you had some schematics showing the connections you made. It would be far easier to understand your setup than reading your description, even if it is really clear and complete. Also, in troubleshooting questions like yours, it is usually helpful to post a really good quality picture showing your board and connection so people can compare it to the schematics and spot any wrong connections you may have made. \$\endgroup\$ – Ricardo Feb 26 '14 at 11:43
  • \$\begingroup\$ If you aren't used to creating schematics, I suggest you try and learn how to do so. Users of this site assume that questions worth answering always come with good schematics, and by the sound of your question, you would benefit a lot from answers from EE.SE. So, why not invest in it? Here are a couple of good resources: tools-for-drawing-schematics and rules-and-guidelines-for-drawing-good-schematics \$\endgroup\$ – Ricardo Feb 26 '14 at 11:45
  • 1
    \$\begingroup\$ Added the picture, USB 5v and GND connected to Vout and GND resply. Battery +ve & GND to Vin and GND resply. USB D+ & D- shorted (even un-shorted/floating gives same result, but since it's a differential connection its better to keep it shorted to ensure it reads logic 0) \$\endgroup\$ – Imran Munshi Feb 26 '14 at 12:26
1
\$\begingroup\$

How much current are you drawing from the LiPo cell? It look like there is a protection circuit on top of the cell. (As there should be) The protection circuit will disconnect the cell if case of over current or under voltage in order to protect the cell. I might just be that you are simply overloading the cell. That would explain the ~0.6V. It is probably the remaining charge left on the input capacitor of the booster circuit.

\$\endgroup\$
  • \$\begingroup\$ I guess you are right, since after connecting 2 cells in parallel (to get 4200mAh) I'm able to use them pretty well. \$\endgroup\$ – Imran Munshi Feb 28 '14 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.