0
\$\begingroup\$

I have a PICkit 2 Microcontroller Programmer, but it is not exactly the one that microchip is selling as PICkit2, I bought it because there is nothing else in my area, anyway, it has USB that connects to computer and send/receive power and data, it is something like this link and software which I use is this link - microchip.com.ru/images/PICkit2_3.JPG - , and the software detect hardware and show exactly my chip ID.

I have tried to program PIC12F629 with the programmer, but it can't write anything and it gives me this error:

"Programming failed at Program Memory address 0x[first address which is not zero]".look like this link - i62.tinypic.com/2jbl55z.jpg - .

I googled it a lot and I have checked with another PIC12F626 and different kinds of Operating system but the same Error appeared. I also tried use MPLAB IDE software but when I try to write the program to micro-controller, it gave me this error :

"The programmer could not be started: Failed to program the target device".

and

" ....

Verifying Program Memory (0x0 - 0x5)

PK2Error0027: Failed verify (Address = 0x0 - Expected Value 0x1683 - Value Read 0x0)

PK2Error0027: Failed verify (Address = 0x0 - Expected Value 0x1683 - Value Read 0x0)".

I also tried to set MCLRE flag off and on software still but no luck.

I should mention my program compile without any error and the IC is supported by my pickit2 board and the company support lines is too busy and the company is too far from me.

Beside of hardware malfunction, any idea why it doesn't work?

\$\endgroup\$
  • \$\begingroup\$ Your links are broken, can you fix it? \$\endgroup\$ – Butzke Mar 6 '14 at 16:47
  • \$\begingroup\$ Is it able to use Microchip's software & firmware? If not, then you're probably on your own (with the company's support line). If yes, then you should try the latest Pickit2 software & firmware from Microchip. \$\endgroup\$ – Laszlo Valko Mar 6 '14 at 21:21
  • \$\begingroup\$ yes , PICkit2 software is detect the device and the chip, but as i said, software can't program the chip. and my software is last version. \$\endgroup\$ – Shombol-shagol Mar 6 '14 at 21:49
  • \$\begingroup\$ Are you sure the PIC is connected properly? There needs to be a decoupling cap on Vcc. You can also try to power it externally, not via the PK2. \$\endgroup\$ – hli Mar 7 '14 at 8:25
0
\$\begingroup\$

I went to company support divition and they told me this kind of pickit 2 clone have some issue with OSCAL value,if it change it to unsupported or out of range value, your chip , in this programmer is doomed , you should get another chip, spacially in 12Fxx series.

They gave me another simpler programmer which is cloned from banner8(German made programmer) to solve the OSCAL problem , it is fine but it is not PICKIT 2.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.