1
\$\begingroup\$

I've been trying to flash an image of UBuntu 12.04 on the cubieboard using LiveSuit(3.05,3.06) on my UBuntu 13.10 and also using LiveSuit(1.07,1.09,1.11) on my Windows7 64bit .

LiveSuit/PhoenixSuit fail to detect cubieboard every time I plug in my device in FEL mode. I've been through most forums on cubieboard and they recommend the very same procedure but it always fails in my case.

1.Start LiveSuit/PhoenixSuit(LS/PS)

2.Turn cubieboard off/Unplug it.

3.Select/Load Image.

4.Press and hold the FEL button and plug the cable to connect Cubieboard to PC and release the button.

5.Upgrade should start automatically.

LS/PS never detect my device at the 4th step. On UBuntu I've checked my drivers using lsmod | grep awusb and sudo modprobe awusb. Executing ./LiveSuit.run installs awusb vers. 0.5 in case of LS3.06 and awusb vers. 0.4 in case of LS3.05. So i guess my drivers are installed properly.Please let me know if I'm mistaken.

I'm not so sure about my drivers in Win7 though. My Device Manager shows a USB Device(VID_1f3a_PID_efe8) however it has an exclamation mark on it. The Device Status in its properties window says --

This device cannot start.(Code 10).

Plugging the device in FEL mode causes no change in the devices shown in the Device Manager nor does it change the aforementioned Device Status. When the device is plugged in normally, a bubble appear on near the taskbar that says --

USB Device not recognized.

Also, a usb device by the name of Unknown Device is added to the list of USB devices with the same exclamation mark on it as mentioned before. The device status of this device says --

Windows has stopped this device because it has reported problems. (Code 43).

After a few seconds it automatically disconnects!

The windows compatible version of LiveSuit doesn't install any drivers though I think they come packed with it. There are 3 files that I believe are the setup files for the driver--

1.drvinstaller_IA64

2.drvinstaller_X64

3.drvinstaller_X86

I don't know which installer to run. I've executed all three but nothing happens apart from a blank cmd prompt window appearing on my screen for a second or two. There also some .sys files in another folder but they aren't executable. I've also tried to update drivers for the aforementioned devices using the device manager by pointing the browse option at the LiveSuit folder.All that happens is that another pops up that says--

The best driver software for your device is already installed.

Windows has determind the driver software for your device is up to date.

This is driving me nuts! Please help!

\$\endgroup\$
  • \$\begingroup\$ If you are reading this and are reputed enough please add a tag named cubieboard to this question. Many people have faced this problem with cubieboard. \$\endgroup\$ – Vineet Kaushik Mar 8 '14 at 5:20
  • 1
    \$\begingroup\$ This is a bit of a guess (never used one) but what happens if you release the FEL button and then quickly plug in the USB port? That Windows error can indicate something at a fairly basic level during enumeration, I had it recently with something where I'd set the USB clock to entirely the wrong rate so it wouldn't have even been starting to enumerate properly. \$\endgroup\$ – PeterJ Mar 8 '14 at 6:15
  • \$\begingroup\$ @PeterJ The same bubble appears that reads USB device not recognizable . \$\endgroup\$ – Vineet Kaushik Mar 8 '14 at 8:04
1
\$\begingroup\$

Is the computer you are using LiveSuit/PhoenixSuit on 32 or 64 bit? If 32 bit the answer is simple, install the 3.drvinstaller_X86. If your PC is 64 bit you would install one of the x64 drivers. However, I am not sure if this will help you out in your particular case. A few other things to check:

Have you been able to turn on your device and start the stock android image? While we are at it do your LED lights turn on, ever? If So, when? Are you using the USB port as a file transfer port as well as trying to power the truck through the USB? A lot of people have had problems during livesuit and phoenixsuit upgrades by using the USB port as both. When powering the cubie truck with 5v 2A 4.0mm power supply the problem seemed to be resolved in most cases. Did you purchase your CT through IO? Check Device Issues with NAND operating system post on Cubie's website as there are two versions of board 3 (AllWinner A20 versions A and B). One is known to have compatibility issues.

Also to try having the power source plugged in to the wall during the upgrade/flash process.

\$\endgroup\$
0
\$\begingroup\$

For me it worked to load the prefered image in Poenix suit, despite it saying that no device was foud. Then I pluged in the cubietruck with FEL button pressed, Phoenix Suit ask if I want to procede with upgrading the firmware (still saying no device attached).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.