1
\$\begingroup\$

I am trying to measure the output of a L7805ACT voltage regulator (datasheet) with a multimeter, without any additional parts (no caps, etc, just the regulator). I'm using a regulated wall adapter power supply with settable output (5-12VDC). The adapter's connector can be inversed so + becomes -, but I paid attention to connect it the right way.

The multimeter I'm using is an EXTECH EX330.

Here's the regulator's pin layout:

L7805ACT pins

Steps:

  • set multimeter to VDC setting
  • attach COM probe to regulator's GND (middle pin)
  • attach red probe to output pin (3rd)
  • connect wall adapter to input pins (1 and 2)
  • switch the wall adapter on

Diagram:

schematic

simulate this circuit – Schematic created using CircuitLab

With the first regulator I tried, the multimeter displays the input voltage and the regulator quickly heats. No voltage drop whatsoever.

At first I thought 12V input is too much, 7V have to be dissipated as heat and that the overheating is normal, so I set the input to 7.5V, but the results were the same.

Changed the wall adapter, same thing. Measured the adapter's output power with the same multimeter, 7.5V exactly as set.

Tried with another regulator, 7.5V input, and now the measured output voltage starts from about 7V and rapidly drops to 0 (didn't really waited to get to 0, don't want to see the regulator burning).

Although the multimeter shouldn't be the problem, as even without connecting it the regulator still heats, I thought to change the multimeter batteries. Low battery indicator was showing on the multimeter, although the batteries were only half discharged. I changed them anyway. Same result.

So what am I doing wrong? Does the regulator need a load on the output, like a resistor? This might sound stupid, but does the multimeter draw too much current from the regulator?

I know this is a basic task, but it got me a little frustrated after possibly destroying 2 brand new regulators.

\$\endgroup\$
  • \$\begingroup\$ Schematic? It needs to be wired up according to the data sheet. Don't forget the capacitors. \$\endgroup\$ – Leon Heller Mar 31 '14 at 11:48
  • \$\begingroup\$ While schematics are always good in this case maybe you could also post a clear photo of the setup? Some of the pin numbers you're using above don't match the numbering in the datasheet, so it's not clear if you're using those or counting left to right. \$\endgroup\$ – PeterJ Mar 31 '14 at 12:00
  • \$\begingroup\$ Left to right, 1 In, 2 Gnd, 3 Out, with the regulator's inscriptions facing up. \$\endgroup\$ – binar Mar 31 '14 at 12:03
  • \$\begingroup\$ Ok, added a schematic \$\endgroup\$ – binar Mar 31 '14 at 12:03
  • \$\begingroup\$ What about the capacitors? Regulators can oscillate without them. \$\endgroup\$ – Leon Heller Mar 31 '14 at 12:13
1
\$\begingroup\$

I suspected that something as simple as this had to have a simple (yet improbable) explanation and it did.

Turns out both regulators were busted. I don't remember where I got them from, they looked unused, but who knows. I tried with the same model but bought at a different time, maybe from another supplier, and works as expected.

The testing setup was correct and filter capacitors aren't really needed (at least for testing purposes), but I'll use them anyway as recommended. Thank you all for your input.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.