3
\$\begingroup\$

I'm trying to export an 8" square design that is mostly copper to Gerber files. The top layer file size is about 14 MB and the board house is complaining that it is crashing their software.

Is there any way to get Eagle to treat the copper areas differently as to not make the Gerber files huge. I'm currently using the Extended Gerber format.

I've read that it has something to do with the representation of the copper layers but I don't know how to change its representation in Eagle CAD.

From "Gerber File Problem 6 – Vector Fills" in a document by bayareacircuits.com:

Often plane layers or layers with shield areas come in filled with 1 mil or 2 mil vectors. This causes the Gerber file to be quite large in size and requires us to try and contourize the data. When you panelize this type of data the files often become too large for our plotter to digest. It is better for areas to be filled using “raster” or “contour” data.

\$\endgroup\$
9
\$\begingroup\$

In Eagle, the copper "polygons" are made up of many parallel overlapping traces. If the polygon's linewidth is set to something small, like 1 mil, it quickly consumes large amounts of data when converted to Gerber.

If you change the polygon's linewidth to something thicker, it will solve this problem. However, it also affects any thermals tied to the polygon, and can cause the polygon's borders to change.

If you need your current polygon settings, then I would suggest that you make a small-width, detailed polygon where it is important, and make a larger, coarse one over the rest of that layer.

\$\endgroup\$
  • \$\begingroup\$ Wow, thanks! That was dead on, the file went from being 14MB to about 600KB... \$\endgroup\$ – pdel Apr 17 '14 at 0:27
  • \$\begingroup\$ Glad to help :) \$\endgroup\$ – bitsmack Apr 17 '14 at 0:38
  • \$\begingroup\$ many thanks for your explanation ! It took me over a day to find the reason for this problem. Hallelujah !! Now the gerber generation takes less then a second, instead of 4 hours. \$\endgroup\$ – Jeremy Jul 21 '17 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.