1
\$\begingroup\$

I need to connect the central pad of the QFN24 to the ground

I got the package from the library that came with the Kicad (libcsm).

Normal QFN24

I tried to edit the module and assign this pad to a number, then I connected it to the ground in the schematic and regenerate the netlist, but it complains about the round-yellow pads (see the image below) that overlaps the square-pad.

Pad near pad

What these round-yellow pads are? Can I remove them? When I tried to edit these pads, it says that they are "NPTH,mechanical" types, what this means?

enter image description here

Thanks for your help.

\$\endgroup\$
1
\$\begingroup\$

NPTH stands for "non plated through hole". It is a hole in the PCB that does not feature plating internally, so there is no electrical connection between the layers. They are used to provide mechanical support, hence the "mechanical" keyword that goes with them.

I do not know why they are there, that's an SMD so holes on the pads are nonsense. Maybe they tried to put vias on the pad for better thermal conduction, but that's not the correct way of doing that.

The error that you are getting refers to the fact that these pads, that probably do not appear in the schematic symbol and then are not connected to anything, are too near. To get rid of it you can either increase the minimum allowed spacing in the design rules (bad idea) or separate them more. I'd get rid of them.

What I think you should do is:

  • remove the NPTH pads from the footprint
  • think if your chip needs extra cooling, then add vias to help that
  • connect the central pad to ground via a copper area. If its purpose is cooling you should not use thermal relief, it's more difficult to solder manually but I hope you are using an oven for such a little guy

I usually do not use the kicad libraries for the footprints. If you start making them on your own and keep them you will have a double gain: you learn to draw footprints and you are sure that what you are using is precisely what you need.

\$\endgroup\$
  • \$\begingroup\$ Thanks for your answer. I just realize that I can not put a via in the middle of the pad, how can I do this? \$\endgroup\$ – koike Apr 21 '14 at 15:25
  • \$\begingroup\$ @koike Are you sure you can't? I just tried it and the DRC did not complain... Is your central pad connected to gnd now? \$\endgroup\$ – Vladimir Cravero Apr 21 '14 at 15:29
  • \$\begingroup\$ I probably did something wrong, I could put a GND via in the center now, thanks. But I also would like to add multiple vias, but the cursor keeps going to the center of the pad, it don't let me add another via in another place of the pad \$\endgroup\$ – koike Apr 21 '14 at 15:40
  • 1
    \$\begingroup\$ preferences>general>disable "magnetic tracks" and/or "magnetic pads", that should do the trick. \$\endgroup\$ – Vladimir Cravero Apr 21 '14 at 15:43
  • \$\begingroup\$ no problem ;) I googled it, you might want to try to search on your own, once you learn that solving problems becomes faster. \$\endgroup\$ – Vladimir Cravero Apr 21 '14 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.