2
\$\begingroup\$

background

Im a beginner in the field of electonics, and I have been trying to put together a IR remote control / laser tag system using Arduino Nano. I am using a TSOP4840 receiver and a TSAL6100 as the emitter, so I need a modulated signal at 40kHz. To do that, I tried to use a NE555timer and use and "and it" with my arduino output pin using a 74HCT08 IC. I made a breadboard circuit. Here's a photo of it: my test circuit

Unfortunately, the timer does not work. Its output pin is always at 0V compared to the GND. I tried a few different timer IC's, none of them worked. I made a second circuit, on another breadboard and using another 555 timer, wiring everything up as in the first circuit, none of it helped.

question

Following the NE555 timer datasheet, I tried to create a test circuit for it, but it didn't work, always having 0V between the output pin and GND. I used different breadboards and timer IC's. How can I identify my mistake/the faulty part of the circuit? I'm quite sure I wired up everything as it was shown in the datasheet. Here is the timers pin layout, the schematic from the datasheet and a picture of my circuit. pin layout astable multivibrator schematic photo

edit the mistake on the photo (yellow wire connected to pin 3 instead of 2) has been corrected, but was not the source of the problem. In the original circuit (top photo) I didnt make that mistake.

\$\endgroup\$
  • \$\begingroup\$ What are your intended component values? Those capacitors look suspiciously small. \$\endgroup\$ – Chris Stratton Apr 24 '14 at 15:31
  • \$\begingroup\$ @ChrisStratton In the secod (test) circuit I used 10nF capacitors and a 2,4kOhm resistor. On the first circuit, I used a 10nF capacitor for the control voltage part and a 22nF and 4,7nF capactiors in parallel with a 1,2 kOhm resistor. I calculated that 26,7nF capacitor and 1,2 kOhm resistor should give me around 41kHz modulation. \$\endgroup\$ – K.L. Apr 24 '14 at 15:35
  • \$\begingroup\$ Double check breadboard connections. I have exactly the same board and sometimes I have issues with connections. \$\endgroup\$ – Kamil Apr 24 '14 at 15:44
  • \$\begingroup\$ I think your numbers for R's and C's are wrong, check them. \$\endgroup\$ – Vladimir Cravero Apr 24 '14 at 15:56
3
\$\begingroup\$

R1 should not be less than about 1K. Shorting it will do bad things, the discharge transistor internal to the 555 will be trying to short the power supply. The 555 may be damaged, and it will not work properly.

\$\endgroup\$
  • 2
    \$\begingroup\$ ... plus, you seem to be missing the connection to pin 2 altogether. \$\endgroup\$ – Dave Tweed Apr 24 '14 at 16:06
  • \$\begingroup\$ @DaveTweed oopsie... Guess I've been staring at this for too long. Corrected that. Still, in the original circuit it was wired correctly, and it does not work. Im looking into the R1>1kOhm thing. \$\endgroup\$ – K.L. Apr 24 '14 at 16:23
  • \$\begingroup\$ .. and the output is wired to threshold.. I shouldn't have stopped at the first issue. ;-) \$\endgroup\$ – Spehro Pefhany Apr 24 '14 at 17:24
  • \$\begingroup\$ @SpehroPefhany yeah, thats the one-row mistake I made, the yellow wire should be connected to the 2nd pin, not the third. I corrected it, but it did not fix the issue - also, it was fine in the first circuit. After correcting that mistake, I followed your advice and put in an 1.2kOhm R1. I changed the R2 to 100kOhm to have a near 50% split between high and low state and adjusted the capacitor to remain around 40kHz modulation. This seemed to fix the issue - the timer output works now :) I'll check it with an oscilloscope once I get my hands on one. Thanks for help! \$\endgroup\$ – K.L. Apr 24 '14 at 19:47
4
\$\begingroup\$
  1. You have no schematic
  2. You have no caps near 555 or on led driver chip, Vcc
  3. You have no current limiting resistor for 1.3V IR LED
  4. No floating CMOS inputs allowed, period.
    1. If LED is direct to driver, it may exceed AGC range of Rx and saturate at close range. Bounce off ceiling if using short circuit cuurent from NAND gate shud work.
    2. You have no test results on voltage of every pin of schematic?

After you get experience, you can walk around every pin, like a dental checkup and figure it out fast.

Ensure you understand the logic trigger states are met

Where is your DMM?

\$\endgroup\$
  • \$\begingroup\$ Wow, I dont understand most of what you said to me. As I said in my question, I'm new to electronics. But I will methodically educate myself on the topics you raised. I didnt provide a schematic for the first circuit, as I tried to isolate the problem and reproduced it on a separate board, and to that I have provided a schematic I have been following (with the exception of setting R1 to 0Ohm, which seems to have caused the problem) \$\endgroup\$ – K.L. Apr 24 '14 at 19:52
  • \$\begingroup\$ This is what I saw in your photo and what you need to learn about filtering and drivers. \$\endgroup\$ – user40708 Apr 24 '14 at 21:28
  • 1
    \$\begingroup\$ You aren't supposed to drive a 1.5V diode with 5V CMOS because the internal microchip current limiting resistor may fuse open with >100mA current limit driving CMOS to a LED which is like a sharp zener (IR diodes have the lowest Vf and series R). This will create current spikes that affect analog timer in 555. But what the heck, it works for hobbyists, but never in production. \$\endgroup\$ – user40708 Apr 24 '14 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.