5
\$\begingroup\$

Ive created two PCBs, a power board to output a +-5V supply and a midway voltage reference (using the TLE2426) at 0V. This PCB powers a biosignal acquistion board shown in the spice diagram below.

The amplifier is an INA129 and the rest of the op amps are AD822ARZ. The power board does exactly as its meant to do, it supplies the board with +-5V and a midway reference voltage for the INA129, however there is almost a 1.3V difference between my floating virtual ground outputted from my power board and my ground plane on my biosignal board.

The V- and V+ are -+5V with reference to the Vref but are +1.3V and -8.7V when measured from the ground plane in my biosignal board, is there anyway to correct/explain this?

enter image description here

\$\endgroup\$
5
  • \$\begingroup\$ I hope you are not using R24 and R25 as a mid-rail generator and are expecting good results. \$\endgroup\$
    – Andy aka
    Apr 29 '14 at 10:13
  • 1
    \$\begingroup\$ @Andyaka - I would assume that R24 / R25 are just being used to set the DC operating point when the electrodes aren't connected. Also, the OP mentions a TLE2426, which is a purpose-specific rail-splitter/virtual-ground generator. \$\endgroup\$ Apr 29 '14 at 10:42
  • \$\begingroup\$ A few questions and comments: (1) Is the offset critical? It looks like you have the first two stages as fully differential. (2) Have you tried putting a trim pot in place of R25? This may allow you to 'null' the offset you are seeing. (3) Although they are different PCB's, do both share a common ground reference, e.g. single point ground? \$\endgroup\$ Jun 2 '14 at 22:48
  • 2
    \$\begingroup\$ I've been studying your schematic and thinking about the issue. It'll help a lot if you could draw a simple sketch of the power and ground connections between the two boards. The ground plane in your biosignal board must not float, but be attached to a proper low impedance source. Typically, you will connect your biosignal board ground plane to either the splitted ground of your power board or to the ground/Vss/negative-rail of your power board, depending on the actual design. The design of the power/grounding interconnection is critical here. Can you tell us more? Could you solve the issue? \$\endgroup\$ Sep 19 '14 at 19:35
  • \$\begingroup\$ I don't see where you connect ground from the power board to ground on the signal board. Of course, you need to do that. \$\endgroup\$ Oct 26 '14 at 19:50
1
\$\begingroup\$

First off your Instrumentation Amp resistors should be high precision types, 1% or better. Without this your DRL circuit, as connected, is amplifying the gain error and DC offsets. (As a side note, the DRL circuit and connection do not quite look correct.) If this circuit must be used in this form with non-precision resistors consider changing one of the 1.8k parts to a 1.5k in series with a 500 ohm potentiometer, then tune to zero with shorted input signals.

Also, your input signals label V+ and V- are confusing while you discuss power supply voltages of V+ and V-, (obviously your input signals would be better named Left, Right, for biomed connections).

As other are hinting, the vref should be used to create the virtual ground with other input, see info below.

Lastly, for more specific info see the TI app sheet/report SBAA188-July 2011, on CM Rejection using Right=Leg-Drive Amp, at:
http://www.ti.com/lit/an/sbaa188/sbaa188.pdf

\$\endgroup\$
0
\$\begingroup\$

Well, not the best engineering way to do it, but in a pinch you could make your supply be +8.7v and -1.3v and with the same virtual ground (maybe) you will get +5/-5 on the other board if the voltage anomalies are really a quantum of 3.7v. I know this does not address the problem, and the problem itself could defeat this 'solution' if the voltage anomalies are dependent upon other factors, but there is nothing to say you couldn't try it - unless you know of a reason not to. I didn't study the baord that much (too small for me to see) but this is just a suggestion. It seems to go without saying that the virtual ground is not in the same 'place' with respect to voltage on both boards, but I think that was what jose.angel.jimenez is trying to say, also.

\$\endgroup\$
0
\$\begingroup\$

The power board does exactly as its meant to do, it supplies the board with +-5V and a midway reference voltage for the INA129, however there is almost a 1.3V difference between my floating virtual ground outputted from my power board and my ground plane on my biosignal board.

This is a common symptom when the ground of the op-amp board has somehow been disconnected from the ground of the power board.

As Michael Fox already mentioned, the ground on the power board must be wired to the ground on the op-amp board in order to function as intended.

\$\endgroup\$
0
\$\begingroup\$

You don't show the connection between your +/=5V supply (including the derived 'false ground)'and the biosignal board.

That's where any problem lies.

The comments regarding resistor matching are of course essential for any board with a pseudo-differential input.

It's essential to label your +/- power and GND or nasty surprises may be in store !

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.