I have a power supply with 12V running into a the common on my PLC. Output 0 on the PLC is wired into a solenoid. The negative on the solenoid runs into the ground on the power supply completing the circuit.

When I power up the PLC and the the external power supply all outputs on the PLC are off and the solenoid is off. When I activate Output 0, my solenoid clicks on as expected. However, when I turn Output 0 back off, the solenoid stays on. The solenoid only turns off if I physically remove the ground wire.


The diagram below gives some insight. Power supply wired to Pin 17. Output 0 (pin 10) wired to solenoid. Solenoid is wired back to ground on the power supply.

If I give the command to turn output 0 on, the solenoid comes on. If I give the command to turn output 0 off, the solenoid stays on.

enter image description here

Link to my cheapo solenoid. http://www.amazon.com/gp/product/B008IG7SWQ/ref=oh_details_o04_s00_i01?ie=UTF8&psc=1

  • 1
    \$\begingroup\$ Ben, what model SSR (solid state relay) are you using? What you are describing is consistent with a situation when an SSR made for AC is used for DC. \$\endgroup\$ May 21, 2014 at 19:59
  • \$\begingroup\$ @Nick: He said "solenoid" and that he heard a click, both of which are inconsitant with a solid state relay. Otherwise, that was a clever insight, but unfortunately doesn't apply here. \$\endgroup\$ May 21, 2014 at 20:02
  • 2
    \$\begingroup\$ @OlinLathrop solid-state-relay seems to be among the tags. At the same time, if Ben posted a diagram of what he is attempting, that wouldn't hurt. \$\endgroup\$ May 21, 2014 at 20:04
  • \$\begingroup\$ Sorry for the confusion, initially I had the PS running through a SSR and was using the PLC to energize the SSR, turning the solenoid (which had the same issue). I then removed the SSR and went directly into the PLC with the solenoid to simplify troubleshooting and had the same result. \$\endgroup\$
    – Ben B
    May 21, 2014 at 20:08
  • 1
    \$\begingroup\$ A lot of solenoids will stay on (once activated) almost down to zero mA flowing thru them. Try putting a 3.3kohm resistor in parallel with the solenoid and see what happens. It could be a few mA leakage thru the opto-transistor. Maybe provide a link to the solenoid too. \$\endgroup\$
    – Andy aka
    May 21, 2014 at 20:47

2 Answers 2


A common problem. Its all to do with the coil on the device, I have had the same issue with energising contactors before.

Try instead to used the PLC output to energise a small relay and switch the solenoid via a relay contact. That should solve your problem.


Based on the suggestions I researched my relay and found the outputs were AC. I spec'd a similar relay with DC outputs and everything worked as intended. Thanks for everyone's help.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.