1
\$\begingroup\$

I'm trying to view my gerbers generated from eagle (using SparkFun's CAM file) as I and cannot get the drill file to import correctly for some reason.

When I drag the files into ViewMate, I choose 0.1mils as the unit of measure for the .dri file and inches for the .gpi file. This is the result:

enter image description here

As you can see, the scale of the holes is messed up.

Here are the Eagle and gerber files.

What am I doing wrong? How do I get it to display correctly?

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

I have run into this exact problem myself. The issue is that Eagle is playing a bit "fast and loose" with the formatting of the drill coordinates, and this causes Viewmate to infer the incorrect scaling. I messed around for a while before I finally wrote a short Perl script that reads in the Eagle file and writes a fresh one with a fixed number of digits for the coordinate values, which Viewmate reads correctly.

Unfortunately, that script is on a different machine, and it will be several days before I have access to that machine again. When I do, I'll add the script here. In the meantime, maybe this is enough of a clue to get you unstuck.

\$\endgroup\$
2
  • \$\begingroup\$ It really seems like there would have to be a setting in ViewMate or Eagle to get this working. Using a Perl script to modify a drill file seems a little extreme! :-) \$\endgroup\$
    – Nate
    Jun 6, 2014 at 13:17
  • \$\begingroup\$ @Nate: Yeah, you would think so, but I played around with both programs for a while, trying to find a combination of settings that worked consistently, and finally gave up. \$\endgroup\$
    – Dave Tweed
    Jun 6, 2014 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.