1
\$\begingroup\$

I'm new in PIC MCU. I wrote program for PIC24FJ256JA106 with TFT-320QVT and all were good, but I decided try option "Code protect". I enabled it and at that time I done mistake. I connected programmer VPP/MCLR pin to PIC VDD and ENVREG pins. Also I connected programmer VDD pin to PIC VPP/MCLR pin. After it I tried write a program to PIC but I couldn't. When I connect VDD and VPP pins correct I can write a program to PIC. Nothing happens when I turn on PIC. Before it my program works without any problem.

What's the problem? Code protect or the mistake with VDD, VPP/MCLR pins connect? I tried disabled code protect but it didn't help.

Pleas, help me! Yuriy.

\$\endgroup\$
  • \$\begingroup\$ What do you mean by "LED blinks, but very strange behavior"? By "the last version of your program", do you mean the program just before you set the code protection? Does this program works only but no other program is working? \$\endgroup\$ – abdullah kahraman Jun 11 '14 at 15:16
  • \$\begingroup\$ Do you have the WDT disabled? \$\endgroup\$ – Spehro Pefhany Jun 11 '14 at 15:19
  • \$\begingroup\$ "LED blinks, but very strange behavior" I mean that blink have do every second, but LED blinks random time. Yes, last version before code protect. Yes, WDT disabled. \$\endgroup\$ – Yuriy Jun 11 '14 at 15:22
  • 1
    \$\begingroup\$ @user45420 I find your question very difficult to understand. I know that English might not be your mother tongue (I am Italian), but please try to edit it and make it clearer because it is impossible to help you now. \$\endgroup\$ – Vladimir Cravero Jun 11 '14 at 15:32
  • \$\begingroup\$ You accidentally reversed the power supply polarity, is that correct? If so, there's a really good chance your chip is blown... \$\endgroup\$ – Dzarda Jun 11 '14 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.