1
\$\begingroup\$

FPGA board (manual)

USB-to-RS232 cable (controller)

synthesis reports

I created a simple schematic which shorts the TXD and RXD pins according to the manual. However, when I use RealTerm to send some data it seems that the result is not displayed at all (nothing is received on the PC). TXD is PIN_G9 and RXD is PIN_G12 but I have tried switching them to no avail.

I have made sure the protocol settings are the same through the Device Manager and RealTerm. What else can I be missing? I'm starting to think there is something wrong with the cable...

\$\endgroup\$
0
\$\begingroup\$

My best guess is that you forgot to load the .qsf file in the Quartus project so that the fitter does not really know what pins you are referring to. Check this, check also that your adapter is working short circuiting the tx and rx pins manually, check that the correct COM port is opened in RealTerm. Your settings look good, just keep in mind that they don't mind at all if you just make a short circuit, as long as you don't use flow control.

If none of the above helps please post the compiler/fitter full report.

\$\endgroup\$
  • \$\begingroup\$ I'm not sure how to short them because the CTS signal is off when it's unplugged. I have added the full report to the post. This is my first time working with interfaces so I'm pretty sure it's some stupid connection issue. \$\endgroup\$ – geft Jul 14 '14 at 22:01
  • \$\begingroup\$ Your report looks quite good to me. You said you swapped TX and RX so we can rule that out too (be extra sure about that). I'd say your adapter is next. Can you please elaborate the "I don't know how to test" part? What CTS are you referring to? Flow control is disabled, CTS should not be a concern at all. \$\endgroup\$ – Vladimir Cravero Jul 14 '14 at 22:08
  • \$\begingroup\$ I shorted the second and third pins (on the wide side) with a screwdriver and still nothing is being displayed on RealTerm. Bear in mind this is my first time using that terminal, and I don't even know how it should look like when it's working. \$\endgroup\$ – geft Jul 14 '14 at 22:24
  • \$\begingroup\$ Here is a video: mediacru.sh/zeJwvO7JuVFf (sorry for the lack of shorting equipment) \$\endgroup\$ – geft Jul 14 '14 at 22:46
  • 1
    \$\begingroup\$ It was indeed a faulty cable. I replaced it with another one and it works instantly. \$\endgroup\$ – geft Jul 15 '14 at 15:21
0
\$\begingroup\$

It was indeed a faulty cable. I used another one and it works.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.