4
\$\begingroup\$

I've got a MAX3232 Serial-to-TTL RS232 board which I am currently using in factory assembly lines. I don't have its picture, but here's a similar product:

Sample

This is the circuit I've managed to figure out of the board(I don't have the original schematic):

MAX3232

I'm using the RS-232 board to send streaming data from an electronic Weight scale to PC, where the data is grabbed by my software for display.

The problem right now, is that sometimes the board stops sending data. I used HyperTerminal to check if the weight scale is sending data or not. When it doesn't, I've tried disconnecting and reconnection the serial port connection, unplugging the serial cable and plugging again, turning off the weight scale and even the PC on/off again and such, sometimes with no results. Sometimes the weight scale (WS) stops sending data. When I left if turned off for a while, and turns it on again, the WS sends data again. I suspect the MAX3232 IC got hot, because I can see the glue I put on the board looking like it's melted off the IC. When it cools down it is operational again.

I've used an oscilloscope to check on burnt ICs - these ones clearly don't have output on pin 14 (refer to schematic), with voltage level nowhere near +- 7V.

I've searched on the internet, and also found other people with issues regarding their IC (well this is actually MAX232) heating up when connecting to PC:

MAX232 overheat problem

MAX232 Overheat

So far I've done some countermeasures:

  1. Replace the burnt/old IC with new MAX3232 ICs from element14. Since the boards were very cheap and made in China the IC were probably of low quality.

  2. Connected the unused CMOS input (pin 10) to GND with 2.2K Ohm resistor.

  3. Added 20 Ohm resistor in series to pin 16 (VCC).

I'm afraid that these measures wont be enough. Maybe I need to isolate my connection. Does anyone have any idea what's going on, and know what to do?

\$\endgroup\$
  • \$\begingroup\$ It looks like pin 8 is a floating input, maybe a resistor to gnd there too? Have you had problems after your countermeasures? \$\endgroup\$ – George Herold Jul 25 '14 at 18:23
  • \$\begingroup\$ I assume pin 11 is not really tied to C5, no? \$\endgroup\$ – WhatRoughBeast Jul 26 '14 at 5:36
  • \$\begingroup\$ @GeorgeHerold - No, both unused inputs have internal pulldown resistors. \$\endgroup\$ – WhatRoughBeast Jul 26 '14 at 5:42
  • 1
    \$\begingroup\$ "Replace the burnt/old IC with new MAX3232 ICs from element14. Since the boards were very cheap and made in China the IC were probably of low quality." - Have any of the replaced chips failed? I ask because counterfeit parts are fairly common when buying from the cheapest seller on Ebay. \$\endgroup\$ – marcelm Sep 27 '17 at 12:30
  • 1
    \$\begingroup\$ TX and Vcc should not be shorted between 16+Vcc and pin 11. \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Sep 29 '18 at 2:11
5
\$\begingroup\$

Just solved this overheating problem on a batch of max232 chips using a couple of resistors. See the input pins 10 and 11 http://www.maximintegrated.com/en/products/interface/transceivers/MAX232.html and click the picture to enlarge. There are supposed to be 400k resistors internally but measuring the resistance to pin 16, I got 40 megohms on this batch. So these pins will be floating and picking up RF and oscillating at a high frequency which in turn will be drawing a lot of current and making the chip hot. I used a couple of 390k resistors as pullups, but anything from 10k to 400k would probably do. Might be worth adding 5K pulldowns on pins 13 and 8 too.

\$\endgroup\$
  • 1
    \$\begingroup\$ I used a keithley to check input current accurately. The datasheet shows 0.3mA typical and 1mA max current consumption at 3v to 5.5v. My two max3232 consume 3.5mA at 3V and ramping up to 10.5mA at 5.5V, lol. They start to get warm at 4.5V and above. I tried your suggestion and it did not change the input currents. \$\endgroup\$ – Ozzy3333333 Jan 27 '19 at 16:50
4
\$\begingroup\$

I have used these 10 x 15mm converter modules from AliExpress for more than 3 years now, probably around one hundred of them. Just recently, on my last 20 or so circuits, I stumbled on this fire hazard issue. I used all the advice I could gather from different forums and I want to share my full recipe in the order I tried them because I reached a really stable behavior which doesn't consume much current and is also protected somewhat:

  1. First, I tried 10k pull-up resistors (on some forums they say that unused TTL pins should be grounded, but I measured some UART pins and for me it makes more sense to pull them up). This increased the stability a bit, but it did not solve it completely.

  2. Next, in addition, I limited the current that module consumes by putting that 20 ohm resistor in series with VCC. Here the behavior was the same as at the previous step, with the change that when the chip would latch up it would get warm, instead of very hot. So I left it like this, considering it a minor improvement.

  3. Next I added 100 ohm resistor on the RS232 pins. Personally I did not notice a change, but there is at least another person on some forum saying that he could see improvements. I tend to believe this, (I'm sorry I cannot mention him. I'm bad with ID's after reading all the posts in a 3 google results page) it will serve as a current limiting protection...

  4. Next, I added a 47uF electrolytic cap on the power pins in between the 20 ohm resistor and VCC. Again same story, somebody else stated that it fixed him. Of course not mine. I left it in circuit.

  5. Next I added a 20 ohm resistor in series on the TTL pins. No change, left it there. May serve as a protection, not to draw too much current from the micro-controller pin.

  6. I moved the power rail from 5V to 3.3V, keeping all the parts mention above. This totally solved the issue for me. At this point I had a procedure developed to make the thing latch. I was powering the converter first, and then connecting RS232 line then disconnecting it and also removing the micro-controller link.

Now I tried all the things I could and I cannot get it to heat up again.

\$\endgroup\$
2
\$\begingroup\$

I had this issue too. Was using 1uf tantalum polarized capacitors. If I unplugged the power while leaving serial attached, then reattaching power, pin 6, the negative voltage source, would go positive ~1v. The chip would heat up and stop working.

For whatever reason, adding a couple .1uf ceramic capacitors for decoupling, in addition to what it called for, fixed the issue. It was VERY reproducible. Now I can't reproduce it. Any EE able to explain? Seems insane.

\$\endgroup\$
  • 1
    \$\begingroup\$ The first half seems like a potential answer to this question but the second-half sounds like you have a question. You might be better to post this as a new question and make a reference to this question to add some context. \$\endgroup\$ – PeterJ Jan 11 '15 at 2:34
  • \$\begingroup\$ Dylan, welcome to EE.SE. Unlike most web forums, EE.SE is a Q&A site, and the space under the question is reserved for answers. Your post is largely a question rather than an answer. It would be a worthwhile question though. Please start a new thread. You can also reference this thread as a related information. \$\endgroup\$ – Nick Alexeev Jan 11 '15 at 6:57
  • 1
    \$\begingroup\$ This is a classic description - and mitigation - of latchup. That you solved the problem makes it an answer. \$\endgroup\$ – Chris Stratton Feb 10 '15 at 3:14
1
\$\begingroup\$

For my application I couldn't lower the power rail to 3.3V as suggested by one of the posters, as I was powering a device using the RTS/DTR pins which needed a higher voltage than the chip was producing at 3.3V.

I ended up using 10K pull-ups on the inputs plus 50 ohm in series with VCC and that solved the problem for me, while keeping the output voltage high enough for my application. I probably could have also used a diode on VCC to drop the power rail to something around 4.0V, and that would probably have worked.

\$\endgroup\$
0
\$\begingroup\$

Don't use a 20 Ω resistor in the VCC line. Place two (BAT85) Schottky diodes as explained in AN218 from EXAR. If still RS232 latch-up add a 1k series resistor in the RS232 input line.

No more latch-ups.

\$\endgroup\$
  • \$\begingroup\$ I've cleaned up your post. Can you add a link to AN218? \$\endgroup\$ – Transistor Mar 11 '19 at 10:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.