5
\$\begingroup\$

Experiment 11 from Make: Electronics

Hi, this'd be my first forum post. I'm really out of options here. Let me get straight to the point. I bought the book "Make: Electronics by Charles Platt" a while back, and I'm currently stuck on the very first part of Experiment 11. It is where you build the oscillator part of the circuit. I'm going to include the parts used, a couple images of my circuit (As I don't have a camera, I had to take them with my webcam), and what I threw together on Fritzing. Be aware that I'm a bit of noob, so I tried to make the Fritzing circuit look as best as I could in the time that I had to post this question. The problem is that the LED is not blinking, it is suppose to blink very rapidly due to the discharges of the electrolytic capacitor in the circuit. But for some reason, the capacitor is not building up voltage to do this. I have a feeling it has something to do with the 2N6027 transistor and how its placed. But I'll let you guys have a look.

2N6027 data sheet - it's a "PUT" - a programmable unijunction transistor.

enter image description here

What I've tried

  • Different layouts like thisenter link description here
  • Rotating the LED to observe polarity
  • Ordered from a different seller, at Digikey
  • I rotated the transistor, every time I did, the LED would light up, but wouldn't blink.

Parts

My Circuit

My Circuit 2

Fritzing picture

I'd appreciate any help I could get! Thank you so much!

\$\endgroup\$
  • \$\begingroup\$ The photos and Fritzing diagram appear to match the book, as far as I can tell. Sanity check: Are the rails powered correctly, with positive (usually a red wire) on the + rail and negative (usually black) on the - rail? And your power supply is 6 volts? \$\endgroup\$ – Dan Sanderson Aug 1 '14 at 4:03
  • \$\begingroup\$ +1 "What I've tried ..." | Pictures ... . || A good start. Sharper pictures are possible with a webcam with more light and care BUT what you posted is better than no pictures. \$\endgroup\$ – Russell McMahon Aug 1 '14 at 5:24
  • \$\begingroup\$ Not sure if it matters, but I see you're using a green LED, not a red one. Red's got a 1.7v forward voltage, green is 2.2v. I don't think it should matter in this circuit, but it wouldn't hurt to probe the voltage across it. \$\endgroup\$ – RJR Aug 1 '14 at 6:11
  • \$\begingroup\$ Thanks for the edit, I'll attempt to make better pictures next time and use some better lighting. As I said in my other comment, the rails are powered correctly. And also I used different LEDs to see if there was any difference. \$\endgroup\$ – Jack Aug 2 '14 at 1:05
  • 1
    \$\begingroup\$ @Jack: There are several things that are strange: (1.) Why do the photos (first two pictures) seem to bee mirrored? (2.) Why don't the photos match the 3rd picture: e.g. in photos 15kOhm, 470kOhm connected to (+)-rail, capacitor is connected to (-)-rail. In the 3rd picture resistors go to (-) rail, capacitor goes to (+)-rail. (3.) In 3rd picture the is a 220 Ohm resitor. It's neither mentioned in part list nor do I see this resitor value in the pictures. \$\endgroup\$ – Curd Nov 7 '14 at 10:29
1
\$\begingroup\$

It's hard to tell from the photo, so I may be incorrect, but it appears that the "G" pin on your PUT is connected to the breadboard, but that nothing is connected to a rail that it shares. It may sound like the obvious, but it helps to double check that everything is firmly connected to the board and that the board is being powered reliably (I.E. No dead batteries, etc.). More often than not, it's simple mistakes that can make a circuit not work no matter what you try. It won't hurt to double check that you have your capacitor and LED polarities correct too.

\$\endgroup\$
0
\$\begingroup\$

I don't have access to the book, but I think I see the problem. I think you've tried all the combinations except the right one.

Your first picture (the linked one) shows everything correct except, as far as I can tell, the LED is backwards.

The second and third images have the 2N6027 backwards, and I can't tell about the LEDs.

So turn the PUT around, flat side to the left. The LED should have a small flat on the side of the base. Connect this side to the PUT and the other to ground. If the LED doesn't have a flat, you should be able to see that one of the leads is longer than the other. This is the anode, and should connect to the PUT.

\$\endgroup\$
  • \$\begingroup\$ Okay, so the output from the AC adapter is 6 volts. I've made sure that all the rails are powered by checking with my multimeter. I turned the PUT around as you instructed, but it didn't really make any difference. I also checked to make sure that current was going through the the rails. I have tried this with a red LED, and it didn't really affect it. There is about 5 volts going through the LED right now. And I have tested the LED to make sure that it works. I do believe that there is a problem with the PUT.. but I've tried this experiment with at least 14 different 2N6027 transistors. \$\endgroup\$ – Jack Aug 2 '14 at 1:00
  • \$\begingroup\$ Also, I checked the voltage going through the capacitor and its 2.04 volts. It doesn't change or anything, and I believe that why the LED is not blinking. I feel like the its because of the transistor, but I've literally flipped it around both ways to observe any difference, but there hasn't really been any other than when it glows when I flip it around. \$\endgroup\$ – Jack Aug 2 '14 at 1:04
  • \$\begingroup\$ That the capacitor voltage is about the same as the expected LED voltage suggests that your 470k resistor is not actually 470k, but something smaller. This keeps the current above the valley current, and the PUT never resets. But the LED current is too low to be visible. Try checking the LED voltage. If it is also about 2 volts, or at least more than 1, check the value of your 470k. Also check the polarity of your 2.2 uF cap. If you've got it backwards its voltage will never get high enough to trigger the PUT. \$\endgroup\$ – WhatRoughBeast Aug 2 '14 at 1:46
  • \$\begingroup\$ Okay, so I turned the PUT around, and It made the green LED glow. The electrolytic capacitor has 2.03 volts running through it, and the LED has 1.791V. Here is my previous circuit --> i.imgur.com/2TBotrZ.jpg?2 I checked the resistance of the supposed 470K resistor, and it says .473M ohms, I got a 470R resistor out its bag and then checked its resistance, it being .473K ohms, I replaced it with the previous one... but nothing changed. \$\endgroup\$ – Jack Aug 2 '14 at 17:25
  • \$\begingroup\$ Any idea on what to do next? ;/ \$\endgroup\$ – Jack Aug 3 '14 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.