7
\$\begingroup\$

I am trying to reduce the power consumption for PIC18F87J11 on sleep mode. The PIC is drawing about .01 mA (6 uA) on sleep mode with Alkaline AAA batteries and other power source, but when I use Lithium batteries the power consumption is higher. It starts low then ramps up all the way to 1.06 mA and remains at that level. I am not quite sure what's different about Lithium batteries that's causing higher current consumption durning sleep mode, maybe someone can shed some lights.

Thanks!

Lithium Battery Specification enter image description here

\$\endgroup\$
  • 3
    \$\begingroup\$ How are you powering this from the lipo? Hopefully not directly, as the maximum supply voltage of that chip is 3.6v and your lipo will deliver most of its useful capacity from 4.2v down to 3.7v. How many AAA cells do you use for that test? How are you measuring the current? It's not trivial to measure in a way that does not disturb the experiment. \$\endgroup\$ – Chris Stratton Aug 1 '14 at 20:15
  • 5
    \$\begingroup\$ Well, that is your first mistake. Section 27.1 of the data sheet you link gives 3.6v as the maximum. Using an amp meter to measure the current is the second mistake - on a scale where the internal loss is low enough to operate the processor and get it into sleep mode, you probably won't be able to measure the sleep current, and on a scale where you can measure the sleep current the internal loss (burden voltage, if not I*R) will probably be too high to allow the processor to boot and enter sleep mode. \$\endgroup\$ – Chris Stratton Aug 1 '14 at 20:25
  • 5
    \$\begingroup\$ I think I might have done something crude with a jumper lead across a micro-amp scale meter to allow it to boot, which I then removed once I thought it was in sleep mode. There have been circuits published for low burden voltage microamp meters, too. Generally I wasn't trying to actually measure the sleep mode current exactly, but to verify that I was in that mode and not a higher consumption one. Remember to watch out for power leaking in via communications or debug cables! Another idea could be to boot it, go into sleep, pull the power, and watch the decline of the filter capacitors. \$\endgroup\$ – Chris Stratton Aug 1 '14 at 20:36
  • 1
    \$\begingroup\$ @Nick: eevblog.com/projects/ucurrent \$\endgroup\$ – Ignacio Vazquez-Abrams Aug 1 '14 at 21:28
  • 1
    \$\begingroup\$ Do you have the REGSLP bit set? See section 24.3.4... Also, as noted above the part is not rated for 4.2V. \$\endgroup\$ – user49628 Aug 1 '14 at 21:55
1
\$\begingroup\$

Provided the PIC is in actual sleep mode and the firmware remains the same there will be no change in current consumption for a given supply voltage.

The change in supply current that you are seeing is likely to be caused by the change in supply voltage.

\$\endgroup\$
1
\$\begingroup\$

If you are powering directly from a lithium battery with its too-high voltage, you might be seeing leakage current through input protection diodes, and that leakage interacting in strange ways with both the microprocessor and the external circuitry.

\$\endgroup\$
1
\$\begingroup\$

If the supplying voltage is higher than 3.6v (which is only suitable for that microcontroller) there must be leakage from its protection diodes that can cause more power consumption.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.