0
\$\begingroup\$

I purchased 2 "Mechanical Relay Board, 8 gang, 10A 220VAC, 24VAC 30ma coil" relay banks that I am trying to control from a raspberry Pi. To do this I've built out 2 595 shift registers and I'm using an external power source, not the power from the pi.

Testing on LED's everything is ok but for the life of me I cannot get the relays to activate. I figured that maybe the input was too small, not enough mA to activate it.

I'm supplying 12v DV from a 12v 1A transformer to power the relay bank and I tried to activate the relays using 5v from USB, 5v from 9v battery running through a 5v regulator, 9v directly from battery and also 12v directly (from the transformer used to power it).

Nothing. I notice that when I test the voltage across the input power terminals, it reads very low (0.10v) but when I unplug the adapter from the relay bank, it reads 12v. So when the power is plugged in to the relay bank, I'm imagining that the bank is causing a fault in the transformer? I noticed that when I had the 9v battery plugged in to the bank as the power source it got really hot.

What am I doing wrong? I changed the jumpers to both positions and tried the same tests on both setups.

Datasheet

\$\endgroup\$
1
\$\begingroup\$

I notice that when I test the voltage across the input power terminals, it reads very low (0.10v) but when I unplug the adapter from the relay bank, it reads 12v.

The relay board doesn't have 'power input terminals'. If you mean the two common terminals, they are both connected to the relays' common connection. So if you connect a supply across them, then you're shorting it out and measuring the drop along a pcb trace.

The datasheet says you can run at 12V DC by setting the jumper (presumably removes a half wave rectifier from the circuit), connecting +12V to the common, then connecting the terminal for the relay you wish to switch to 0V. You don't seem to have tried this.

If you want to run it from arduino level, use a FET which turns below 5V and connect the FET between the relay terminal and ground while supplying 12V DC to the common terminal.

\$\endgroup\$
  • \$\begingroup\$ You're right, it does say common. I tried it and it worked, the relays activated. \$\endgroup\$ – DustinDavis Aug 7 '14 at 18:04
2
\$\begingroup\$

The coils require 12v or 24v (depending on jumper settings), AC not DC.

The MRB-8-12VDC version uses DC for the coils.

\$\endgroup\$
  • \$\begingroup\$ I must have misunderstood the data sheet. I thought it could use 12vdc or 24vac. Makes sense. What about the trigger source, do you think 5vdc will be sufficient or is there a certain amperage I need to meet? \$\endgroup\$ – DustinDavis Aug 7 '14 at 7:07
  • 1
    \$\begingroup\$ To activate a relay on that model, you will need either 12 or 24 AC. That will switch the high voltage side. In order to use 5v, you will need a FET that has a 5v gate. The FET will switch your 12v or 24v AC line that triggers the relay coil. You may want to find a board that uses relays with 5vDC coils in order to simplify the required circuit. \$\endgroup\$ – Enemy Of the State Machine Aug 7 '14 at 7:19
  • \$\begingroup\$ The data sheet states that there are two versions of the boards, not four. I think the last part of the model number specifies the factory default for the jumper settings. \$\endgroup\$ – Pete Kirkham Aug 7 '14 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.