2
\$\begingroup\$

I'd designed a USB-JTAG Programmer with FT2232D. I programmed Xilinx spartan3 FPGA 2 times yesterday and everything was perfect. But today when I connect it to my laptop I see the following message: "USB device not recognized"

SB device not recognized Device manager

I saw a post about same problem: "If enumeration is failing, something in the hardware is broken. This could be a damaged chip (make sure you always power the chip completely , so don't let VCCIO be unpowered if you power VCC)."

I've connected the VCCIO of the FT2232D to the VCC of the FPGA board with a jumper, so when the FPGA board is off VCCIO can be unpowered.

Can anyone tell me wheather my chip is damaged or not? Or how I can check it?

Here is my board's schematic:

schematic


Note: My laptop has windows XP SP3 media center edition, I've also tested it on win7 64bit but it didn't work.

\$\endgroup\$
  • \$\begingroup\$ Design looks sensible and you say it worked yesterday, something must have changed (broken?) in the hardware. I assume your Spartan3 is using 3.3V logic levels on the JTAG pins; the Spartan3 is more vulnerable to overvolage damage than the FT2232H if I remember correctly. Check the USB connector, some USB-B connectors have a back shell that can intermittently short the D+/D- lines. This would explain Windows detecting USB device present, yet unable to Enumerate USB device. If you have an oscilloscope, verify XTOUT clock is running. Anything different in your project since it last worked? \$\endgroup\$ – MarkU Aug 25 '14 at 0:46
2
\$\begingroup\$

Finally the problem has solved.

I cleaned the board with board cleaner again and reinstalled the driver.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.