0
\$\begingroup\$

I am evaluating a few sensors for an application at work, and I'm having some troubles figuring out the correct way to connect/test this sensor: Gems Sensors' CAP-150. Datasheet here. I want to connect it later on to an ATMEGA324PA.

I know I'm using the Dry Sink variant, but I can't make any sense of the BLK/BLU switch diagram, nor the 300mA max load.

What I think I should do is supply the sensor with 5VDC at the BRN wire, GND to the BLU wire and then check the BLK wire for status change at one of the ATMEGA's pins. Although, the 300mA warning is confusing me, because it's specified as "continuous switching current" - on the other hand, the current consumption is rated at under 10mA.

I know that the ATMEGA can source the 10mA without any trouble, but does the 300mA warning mean I can't supply beyond that current to the sensor? In the configuration I described, is there any scenario where this could happen?

Can anyone help me clear this out?

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

For "Load" connect a resistor of perhaps 1K from BLK to 5V. 5V to BRN, GND to BLU.

Measure the voltage when 'Low' at the black wire with a voltmeter (to GND) - the guarantee of 2V is a bit close to the maximum but I bet that with 1K the actual voltage will be more like 0.2 to 1V and it will work fine connected directly to the microcontroller input.

The 10mA comes from the power supply, not the Atmega, so no worries. 1K will draw an additional 5mA when low, again from the power supply.

\$\endgroup\$
3
  • \$\begingroup\$ Thanks for helping! So, just to clarify, if I want to read it to one of the ATMEGA pins, you think I should do it connecting the BLK wire to the pin with a parallel 1k resistor? \$\endgroup\$
    – Joum
    Commented Aug 27, 2014 at 11:12
  • \$\begingroup\$ Yes. Check that the voltage levels are appropriate with a multimeter first. You can't hurt the Atmega with only 5V (assuming that's the supply on the Atmega) but it might not be reliable. \$\endgroup\$ Commented Aug 27, 2014 at 11:19
  • 1
    \$\begingroup\$ Already tried it. As it is a "dry" sensor, it becomes active when "dry", meaning that when active, it reads 4.9VDC at the BLK wire, and 0.72VDC when inactive (low/"wet") - just as you predicted. Great tips, @SpehroPefhany, thank you for all your help! \$\endgroup\$
    – Joum
    Commented Aug 27, 2014 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.