I am having a pretty strange problem that I am unable to solve. Basically, I am using an L7805CV and it is outputting at 5.8V instead of the specified voltage range in the data sheet. At first I was using it in a digital isolation scheme, but when I was unable to solve the problem I took it out and breadboarded it by itself. I am using the caps specified in the data sheet, .33uF and .1uF

Things I have thought/tried:

  1. Maybe something is iffy with the voltage supply. I've tried 19V and 12V supplies, each providing the same result.
  2. Maybe the regulator is just faulty. I tried three different L7805CVs, all of them having the same result, albeit slightly different output voltages.
  3. Maybe the circuit isn't under enough load. I tried 1k and 100 ohm resistors and it didn't change the end result. With no load it still gives the same result.
  4. Maybe the caps are non-ceramic. They are ceramic.
  5. Maybe the caps are bad. I have a voltmeter with support for capacitor testing so I checked each of them and they were each within range.

Things you might be thinking:

  1. Maybe it's the breadboard. Yeah, well, it isn't. At the very least I believe it isn't. I had the original one in a PCB and it was behaving the exact same way.
  2. Maybe you're an idiot. Yeah, well, yeah.

The power supplies I'm using are a 12VDC switching supply, and a 19VDC Acer computer charger I cut the end off of.

For a relevant circuit diagram check the application circuit for the L7805 which I'm sure most people here are familiar with.

After failing with the L7805 I threw in another regulator I had on hand (I can't remember the number but it's 5V) and it worked fine. A pristine 5.17V, well within range of the data sheet.

Using a 1N4148 diode I can drop the voltage within spec on the L7805, but that is, of course, cheating.

  • 1
    \$\begingroup\$ Wired up correctly? Sure it's a 7805 and not a 7905? \$\endgroup\$
    – Andy aka
    Commented Sep 18, 2014 at 22:57
  • \$\begingroup\$ I'm absolutely positive. I know that it is wired up correctly. I had my brother, who also has electronics experience look over everything and verify that I had wired it correctly. \$\endgroup\$
    – Ishi
    Commented Sep 18, 2014 at 23:01
  • 1
    \$\begingroup\$ Post a close-up photo of your wiring on the breadboard. Maybe fresh eyes will see something you're overlooking. \$\endgroup\$
    – Dan Laks
    Commented Sep 18, 2014 at 23:19
  • 3
    \$\begingroup\$ Dodgy batch from some unscrupulous supplier? Maybe double check your voltmeter? \$\endgroup\$
    – Andy aka
    Commented Sep 18, 2014 at 23:19
  • \$\begingroup\$ Andy I think you might be on to something. The batteries are on their way out on my meter but I hadn't considered it would effect readings since it powers on and acts normally otherwise. That's hilarious if it ends up being the case. \$\endgroup\$
    – Ishi
    Commented Sep 18, 2014 at 23:25

1 Answer 1


I think you may have already checked for most of the topics in the list bellow. However, I have tried to make an exhaustive list that will surely help others arriving this question.

The usual suspects when dealing with issues with the 78xx standard linear regulators:

  1. The output may be oscillating, which may be difficult to verify if you only have a digital multimeter at hand. Check, if possible, with an oscilloscope. Possible culprits:
    • Follow the manufacturer's recommendations for input and output capacitors. Not all capacitor technologies (Aluminum, Tantalum, ceramic) are allowed. Not all values are allowed. Check also the range of input/output capacitance for stable operation. There is usually at least one section in the datasheet devoted to stability.
    • Check that you are respecting the minimum/maximum input voltage for the regulator. Minimum input voltage could be as high as Vout + 2.5V, depending on the device. Maximum input voltage varies hugely among different devices. Again, check the datasheet.
    • Check that a minimum load current is required from the regulator. Some devices are happy with very low load current (<1mA), however, many 78xx devices will require a minimum load current for stable operation.
  2. If the output voltage is higher that it should be:
    • Check that the ground is not being "pulled up". Most 78xx devices can effectively work with a "virtual ground", that is, if you insert a resistance from the common return to ground, the reference voltage and the output voltage will both rise by V=R*I, being R the common path resistance to ground and I the quiescent current plus load current.
    • The device may be broken, faulty or a counterfeit. Simply check with another sample, even best if you can try a sample from another batch.
  3. If the output voltage is lower that it should be:
    • Check that you are respecting the minimum voltage drop required by the regulator. Check the datasheet. Some non LDO devices may require the input voltage to be up to several volts higher than the specified output voltage.
  4. Check your measurement devices. If possible, try more than one DMM. Check your batteries. Even better, check the signals with an oscilloscope.
  5. Check your power supply: real output voltage, noise, current capabilities...
  6. Check your connections. Twice. Lots of the electronic issues during the prototyping phase can be traced down to bad connections or mafunctioning breadboards.
  7. Check the pinout of your device. Make sure you are wiring correctly the ground, reference and output connections.
  8. Beware of shorting the input of your voltage regulator. Many of the 78xx devices cannot withstand a "short" in the input capacitor while the output capacitor is still charged. This will usually damage permanently your device, totally or partially (even worse), which could explaing the strange behaviour of the device from than point on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.