2
\$\begingroup\$

I’m working on a VHDL project which is a small SDRAM test. I have these entities:

  • top
  • sdramwrapper
  • sdram <– generated IP core sdrampkg <– contains a package containing constants used several places and a couple of type's to bundle signals

ISE usually organizes the implementation files in a tree and automatically determines the required compilation order. However, in this project it refuses to include the sdram_pkg package when building and thus I have to use manual compliation order. In itself it is silly but works. When I try to simulate the project it refuses to include the sdram_pkg package at all, even if I’ve specified the compilation order.

I'd like to know both how (figure out how) to solve this problem, but also know the rules ISE uses.

Update: By marking the sdram_pkg.vhd file as "global source" it was included and I can use the automatic compliation order.

\$\endgroup\$
2
  • \$\begingroup\$ Which version are you using? \$\endgroup\$ Apr 17, 2011 at 18:23
  • \$\begingroup\$ 12.4, 64bit Linux \$\endgroup\$ Apr 17, 2011 at 18:41

1 Answer 1

1
\$\begingroup\$

It sounds like you figured out your problem, but you can indeed set a custom compilation order in ISE. For example, see this link: Setting a Custom Compilation Order (part of ISE help).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.