0
\$\begingroup\$

I have been working to redesign a faulty circuit board.

One of the problems I have identified is the power supply on the board.

The input voltage is nominally 13.8V DC from an AC switchmode powersupply but can drop sharply by about 1.5V when a number of solenoids that are connected to the same voltage activate and draw a large current. When the device is operating off the backup lead acid battery the input voltage becomes 12V.

Currently they are using a small SMD 7805 LVR to produce the 5V supply for a microprocessor and RFID chip. The LVR chip is overheating and heating up the whole circuit board (some parts are too hot to touch) which I am going to fix by using a TO-220 and proper heatsink.

However the change in the supply voltage causes a 100mV change in the 5V output before the LVR recovers. I think this may be causing the RFID's output frequency to fluctuate temporarily causing it to lose track of tags.

What is the best way to fix this? Would it be better to switch to one of those miniature DC-DC switchmode supply daughter boards combined with a LDO?

EDIT:

Current figures: Worst case current through LVR is ~400mA, have measures up to ~300mA. From memory each solenoid draws ~200-300mA when on, but they are latching solenoids so they are only momentarily on. Each circuit board operates one solenoid, and depending on the product there can be up to 50 circuit boards and solenoids driven from the same 13.8V power supply.

They were having worse problems voltage drop due to running the circuit boards off a shared 5V line run over several metres of ribbon cable (with two conductors), but they then put the LVR to run off the 13.8 to get around that. They then had problems with the 13.8V line also run over the ribbon cable (five conductors) so they started running 16AWG lines to junction boards along the ribbon cable. They also chucked some big electrolytic capacitors on the ribbon cable but I don't think it made much difference from my testing.

The relays are near the board due to the physical layout of the product so not much can be done with that except to carefully design the board to prevent noise getting into it. It may be possible for the RFID antennas to pick up a bit of noise as they are on a long lead up to 0.5m, but only some of the lead is on the circuit board side of a steel plate, the wires then pass through a small hole so I don't think they pick up noise after that.

EDIT 2:

Should also mention all 50 relays sometimes get activated at once (can't change that unfortunately). However I have seen the voltage drop with just one relay activating which is puzzling, and it seems to be mainly when the relay is pushing out (instead of when it pulls) unless I am imagining things.

\$\endgroup\$
  • 2
    \$\begingroup\$ You've got a lot of voltage numbers, but we need to know how much current also. It sounds like your power supply doesn't supply enough current. Do the solenoids operate off the 12/13.8 V or the 5V? A circuit diagram is always helpful. Perhaps bigger caps to reduce the supply droop. The over heating of the 7805 is a result of the power it must dissipate, voltage drop (13.8-5) 8.8 V times the current. \$\endgroup\$ – George Herold Oct 3 '14 at 12:31
  • \$\begingroup\$ Just whack some massive capacitors on there mate. She'll be right \$\endgroup\$ – KyranF Oct 3 '14 at 12:58
  • 1
    \$\begingroup\$ Do the relay coils have suitable flyback diodes? \$\endgroup\$ – Andrew Morton Oct 3 '14 at 23:43
  • \$\begingroup\$ That was one thing I was concerned about since there isn't a flyback diode on the current design. But the MOSFETs have internal diodes. Do they do the same job? I am currently redesigning this part of the circuit anyway as they were trying to drive 12V solenoids directly from a MOSFET driver chip (so only ~9V high to low) which was causing the solenoids to jam occasionally. I am going to put in a proper H-bridge with power MOSFETs so I will look at adding flyback diodes too. \$\endgroup\$ – ljbade Oct 4 '14 at 1:49
  • 1
    \$\begingroup\$ The internal diodes in the MOSFETs will protect the MOSFETs from the voltage spike when they switch off, but they won't stop that spike from being injected into the positive rail (in fact I think they'll worsen the latter problem). You should definitely fit flyback diodes across the relay coils and that would now be my prime suspect for the cause of the glitch you're seeing. \$\endgroup\$ – nekomatic Oct 4 '14 at 13:59
4
\$\begingroup\$

There are several problems here.

Turning on the solenoids causes a significant short term drop on the supply voltage. The actual voltage level doesn't seem to be a problem, but the rapid dip is. The obvious fix is to make less of a dip with slower edges. Put a bulk capacitor accross the power input right where it enters the board, and put smaller caps near the relays right where they draw power. Pay attention to the loop current thru these caps, and the overall relay power currents accross the board. The problem you may really be having is ground bounce when the relays kick in due to bad ground design. It would be best of the relay return currents did not run across the main ground plane, but had a separate return to the main ground point at the power supply feed.

Problem two is that your low voltage supply is susceptible to fast transients on the input. Since you have lots of voltage headroom, a little filtering in front of the 7805s will slow down the edges to where the active circuitry in the 7805 can deal with then, and also take some of the heat load.

Problem three is that the linear regulators are getting too hot. This is because they are dropping the difference from the power supply voltage to the 5 V logic supply times its current as heat. For example, let's say you need 100 mA at 5V. With 14 V input, the regulators are dropping 9 V, which times the current comes out to 900 mW. That's likely out of spec for a small surface mount part.

Adding larger regulators with heat sinks will be bulky and expensive. A better answer is to use a small buck regulator. Even if it is only 85% efficient (pretty low by today's standards), the same 100 mA at 5 V out will cause less than 100 mW dissipation. It can be small SMD parts without any special thermal considerations. One switcher should be good enough for all your 5 V needs.

If you need extra clean 5 V supplies, you can have the switcher make 5.6 V or so and use small low-dropout linear regulators at the point of usage. These won't get hot since they would only be dropping the 600 mV times the 5 V current. Put a small ferrite chip inductor followed by cap to ground in front of each LDO.

Another thing to do is to put a Schottky diode followed by a cap to ground in front of the switching regulator. This will prevent sudden drops in the input power voltage from forcing the input of the switcher low. The resulting transient will be slow enough to give the switcher a chance to deal with it properly.

\$\endgroup\$
  • \$\begingroup\$ Good idea about the grounds, how can I check for ground bounce? I also think that you are right about using capacitors to reduce the voltage dips and transients. They say they have looked at DC-DC power supply but they had the idea that it was expensive. I will take another look at the idea then as it may be cheaper than a heatsink. However I have come across some surface mount heatsinks from Aavid for SMDs that according to my calculations will be OK. Thank you for your ideas they seem like they will work. \$\endgroup\$ – ljbade Oct 3 '14 at 22:55
  • 1
    \$\begingroup\$ @NZG: From the added info in the question, we can see that the power supply to each board has significant impedance. You definitely want to put a cap across the power on each board right at the connector. Another advantage of switchers is that there will be less overall current draw, so less supply droop to each board, and probably more importantly, less worst case ground rise. Make sure there are diodes for safely dumping the relay coil energy when it is turned off. \$\endgroup\$ – Olin Lathrop Oct 4 '14 at 11:52
2
\$\begingroup\$

Instead of replacing the onboard 7805, you could try using an intermediate (linear or switching) regulator to drop the supply to 8 - 9 V or so - still high enough to give the 7805 sufficient headroom but only requiring it to dissipate half the power. That should also reduce the dip you see on the 5 V rail by an order of magnitude, assuming that the dip arises from poor line regulation by the 7805 - you might want to check that your circuit doesn't share a ground return path with the solenoids, for example.

How close are the solenoids to the RFID device though? Could it be the magnetic field from a solenoid coil that's causing the problem, not the voltage drop?

\$\endgroup\$
  • \$\begingroup\$ Added detail about the RFID and relays. \$\endgroup\$ – ljbade Oct 3 '14 at 22:53
  • \$\begingroup\$ Also good idea about ground path, yes they do share the same ground for 5V and 12V. \$\endgroup\$ – ljbade Oct 3 '14 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.