I am using a Microchip Bluetooth Pictail and a Sparkfun 3.3V USB-to-UART and a Arduino Uno (just for power-5V,gnd and 1 active high signal connected to 3.3V).

When I power the PicTail it outputs "CMD" to Realterm, but won't accept input (like a "H\n" for help). I see the Tx pin light up on the Sparkfun. The weird thing is, when I disconnect the 5V, it works great for like 10 seconds. I know it's running off bypass caps. Has anyone an idea what could be wrong? I checked the regulator output on the PicTail, its 3.3V, like it should be.

enter image description here

  • 1
    \$\begingroup\$ Can you post a schematic? What's the power supply level of Bluetooth Pictail? \$\endgroup\$
    – diverger
    Commented Nov 4, 2014 at 6:48
  • \$\begingroup\$ The PicTail takes 5V from the Uno. The Pictail has a 3.3V regulator, so everything on the PicTail is 3.3V. The Sparkfun is 3.3V. I will post a schematic of the PicTail. \$\endgroup\$
    – Bill
    Commented Nov 4, 2014 at 22:20

2 Answers 2


This smacks of a grounds-not-tied-together issue. It looks like the USB-to-UART device has only 2 lines going to the Pictail board. I would presume those are just the UART Tx and Rx lines, and not ground.

If the grounds of all three boards are not tied together, digital signals between the boards will be interpreted incorrectly and will lead to undefined and/or sporadic behavior.

Tie the ground pin of the USB device to either of the other two boards and that may fix the problem.

  • \$\begingroup\$ Agreed, he's probably powering the Uno off USB to his computer, and the other device is probably powered by some form of battery. In the picture though, it DOES look like the 5V and GND pin on the left side of the Uno are being connected by the long white wires to the Pictail board. It is very possible that the wires themselves are faulty/old/poor connection/high resistance and are showing signs an symptoms of a faulty ground/power connection because of that \$\endgroup\$
    – KyranF
    Commented Nov 4, 2014 at 11:58
  • \$\begingroup\$ The Uno and the Sparkfun are powered by USB. The PicTail is powered by 5V from the Uno. The PicTail has a 3.3V regulator. The Sparkfun is a 3.3V device. I thought since everything is powered by USB, the grounds would match. \$\endgroup\$
    – Bill
    Commented Nov 4, 2014 at 18:48
  • \$\begingroup\$ Presumably the grounds should be tied together within the USB hardware in your computer, so I agree with you. Just to eliminate possible ground reference shenanigans though, connect a wire from the ground of the Sparkfun device to the ground of one of the others. If that doesn't fix it, then my answer isn't the solution. \$\endgroup\$
    – Dan Laks
    Commented Nov 4, 2014 at 18:59
  • \$\begingroup\$ I tried tying the grounds together but it didn't fix the problem. The board isn't being powered by the bypass, it is being powered by the GPIO I have at 3.3V. The module reads 2V. Still no idea what is wrong. I opened a ticket with Microchip. \$\endgroup\$
    – Bill
    Commented Nov 5, 2014 at 5:15

In the User Guide of the PicTail they say to jump JP1 to be in UART mode. I checked the schematic again and JP1 only works with the PIC motherboard is plugged in. JP1 is for holding the PicTail onboard PIC in reset. I hooked JP1 pin 2 to ground and it began working. The onboard PIC must have been holding onto the UART lines. Here is my new setup. I got rid of the Arduino and are just using the Sparkfun USB-to-Uart.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.