0
\$\begingroup\$

I connected MSP430 Launchpad to the PC, but when I click download and debug it shows this error

Fatal error: Failed to initialize. Check if hardware is connected. Check if drivers are installed. Try to restart the computer. Tools using the parallel port are not supported on Windows

update: Ok I solved it. I connected to the another USB port.

\$\endgroup\$
  • \$\begingroup\$ Have you tried the Launchpad support forum? \$\endgroup\$ – Leon Heller May 1 '11 at 15:51
  • 1
    \$\begingroup\$ your questions are generally of low quality and hard to understand, and mostly in the "please do not ask questions of this type" category of our FAQ. Please, take a look in the how to ask page \$\endgroup\$ – Daniel Grillo May 2 '11 at 19:26
  • \$\begingroup\$ Another aspect of the FAQ is that you can answer your own question. People won't look in the question for the answer, they'll look for the answer with the green check mark. You should pull your last sentence out of the question, paste it as an answer (possibly with some additional information on how you discovered the problem, or why you suspect that the initial USB port didn't work), and mark it as the solution to your problem. Thanks! \$\endgroup\$ – Kevin Vermeer May 4 '11 at 16:02
1
\$\begingroup\$

On Windows "Device Manager", under the node "Ports (COM & LPT)" check there is a "MSP430 Application UART (COMx)" (x should be a number depends on your pc). Then on IAR, open your project options, under "General Options" category, make sure you selected Device as MSP430G2231 or MSP430G2001 (which you use), under "Debugger" category select Driver as FET Debugger, under "FET Debugger" category select Connection as Texas Instruments USB-IF.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.