1
\$\begingroup\$

Im trying to use a static relay for the first time. It is an HFS5, supposed to turn on/off at ~5V.

Soldering is not clean but I have triple checked with a multimeter that the connections are ok on lines 1, 2, 3 and 4, that the relay's pins are connected to the lines and that there are no shorts.

1 and 2 are connected to a tablet's 5V DC charger and I checked the voltage is ok on the HFS's input.

However, when I plug in the charger / putting 5V between lines 1 and 2, the connection does not happen between lines 3 and 4 (checking with the multimeter again)

Any idea what can be wrong in your experience ?

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Did you try putting the minimum load voltage on the outputs? \$\endgroup\$ – Ignacio Vazquez-Abrams Nov 10 '14 at 10:05
  • \$\begingroup\$ nope, but what is the reference 0 voltage for the output ? \$\endgroup\$ – Thomas Nov 10 '14 at 10:05
  • 1
    \$\begingroup\$ There's a connection diagram on the last page of the datasheet showing how to attach a load. To test it maybe attach an incandescent light bulb and that will save you poking around at mains voltages while running. \$\endgroup\$ – PeterJ Nov 10 '14 at 10:17
0
\$\begingroup\$

The relay is a photo triac circuit and the "contact closure" may not be easily proven with a multimeter because there will likely be not enough voltage generated by the multimeter test leads to overcome the forward volt drop of the triac when it conducts.

Here's the general idea: -

http://www1017.vu.lt/legacy/pfk/funkc_dariniai/images/triac_iv.gif

Without significant current to pass the minimum holding current (a few mA) the meter is unlikely to register anything other than a bit of leakage current. Also if you read the data sheet, the load current range is 0.1 A to 2C and no way will your meter meet the minimum requirement.

Having said all this, please double check you have the photodiode polarity correct - if you think this has been wired incorrectly at any time there is a possibility the device is damaged beyond repair.

\$\endgroup\$
  • \$\begingroup\$ with a load it works, I was pretty afraid to try with one (220V) and breaking some fuses in my house. Thanks ! \$\endgroup\$ – Thomas Nov 11 '14 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.