I am trying to charge a device (not of my own invention) with a solar panel. Sorry for the lack of name, but I’d like to keep my project my project. The panel is rated for 4.8v at 100 mA, and the device charges via micro usb: 5v at 500 mA (approx.). The device has to be turned on while charging. I am not necessarily trying to keep it at 100% charge, but to prevent it from dying for an extended period of time. The device connects to a smartphone or a tablet via bluetooth. The problem I’m having is during charging with the solar panel.The charge would be stable (at around 60%-90% or so) but the bluetooth connection would drop.   
   In the control tests, with the device functioning regularly without a charger, the battery life was about 6 minutes and 15 seconds , but the connection here dropped at about 4 minutes and 15 seconds with what should have been a stable battery life. It is registering that the unit is charging with the panel.   
  I tried decreasing the distance from my light source to bring the voltage up to 5, but that didn’t change the effects.   
  Due to the fact that the unit emits a quiet buzzing sound while being charged with the solar, I believe there may be a switcher in the power regulation circuitry. When charging with the panel, the noise is like the Doctor’s sonic screwdriver, except at both a slightly high pitch, and a lot quieter. While charging via usb (from lightly used iPhone charger), there is no noise. I’m no expert, but I think the small spikes in current it produces may be interfering with sensitive bluetooth communication. Another high frequency in the device is the communication to an onboard motor, which may also be causing some interference due to the less precise (precise, not accurate) charging from the solar panel, as the device vibrates slightly uner the light. I’m really not sure. I will get an oscilliscope in a week or so, and I’ll hopefully be able to check any spikes. Due to the battery life and the size, I wouldn’t guess that it contains very high quality components, though the Bluetooth connection is rated for 180 feet.   
  To help smooth out the power coming from the panel, I put in two capacitors in parallel with both each other and the main circuit, though this didn’t help. One was 470 microfarads, and the other was 0.2.   
  Just out of curiosity, does this sort of thing (error while charging with solar) happen often? I couldn’t find anything on google.
  Thanks for any help! :)


1 Answer 1


A USB device requires that the input voltage be 5V (4.40-5.25V). If the voltage is nonzero but outside that range, the device may malfunction or be damaged; certainly it can't be expected to charge its battery when input voltage is below spec. It is not appropriate to connect a solar panel directly to the USB input of a device because the voltage can't be guaranteed to fall in that range. You really should have a buck-boost regulator between the solar panel and the USB device.

It wouldn't surprise me if the device failed to maintain a Bluetooth connection when the USB input voltage is out of spec. If it fails when the input voltage appears to be within spec, that suggests one of two possibilities:

  1. The input voltage isn't really as stable as it appears. Check with oscilliscope on multiple time scales for noise or drops. Voltage drops can occur when there is a surge in current consumption by the device, such as when it transmits. A filter capacitor could be needed.
  2. The device is damaged or broken. Check whether it can maintain the connection when powered from a normal USB charger.
  • \$\begingroup\$ I did test it with a multimeter, and adjusted the lamp distance with battery life tests at 4.8v. When not connected to the panel, it still worked, and stayed connected to my smartphone. Thanks for the advice about buck-boost regulator, and filter capacitors. I'll test that as soon as I can obtain some. \$\endgroup\$
    – Keychain1
    Nov 19, 2014 at 3:12
  • \$\begingroup\$ I assume that suitable ready-made buck-boost regulator modules are probably sold for exactly this purpose, but I haven't searched for them. \$\endgroup\$
    – Eric Smith
    Nov 19, 2014 at 12:09
  • \$\begingroup\$ I found one on Adafruit, and it worked great. Thanks! \$\endgroup\$
    – Keychain1
    Dec 6, 2014 at 9:49
  • \$\begingroup\$ Did that help with your connection loss problem? \$\endgroup\$
    – Eric Smith
    Dec 7, 2014 at 1:36
  • \$\begingroup\$ Yep. Do you know how to mark this question as solved? \$\endgroup\$
    – Keychain1
    Dec 7, 2014 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.