3
\$\begingroup\$

alt text

I bought about 10 ATMEGA168V's (which I thought were P's) and tried to flash with TinyISP via the Arduino IDE with the arduino mini pro board selected. Well this fails for the obvious reason that the mini does not use the ATMEGA168V. The lilypad actually uses the V.

Now when I try to:

avrdude -c tinypisp -p m168

I get an error that tells me to recheck the connections. However I know the connections are fine since I was able to get the fuses set msg with this very same command BEFORE I tried to flash it with the Arduino IDE.

I applaud you for getting this far into my rambling back story. The question is are these chips now dead? Is there something I can do to get these guys talking to avrdude again?

Thanks,

Ril3y

\$\endgroup\$
4
\$\begingroup\$

It looks like the breadboard where you're burning doesn't have a crystal, although that could be hidden behind something.

Burning the bootloader will also set the fuses... which will set it to require an external oscillator. You'll have to add an oscillator to the system to get it to talk to the ISP again.

Could that be your problem?

|improve this answer|||||
\$\endgroup\$
2
\$\begingroup\$

I ran into the same issue with a regular atmega168. I was able to initially communicate with it using avrdude, then I plugged it into the arduino board and tried to flash it using the IDE. The error I got was:

avrdude: initialization failed, rc=-1

I was using the wiring scheme from a Sparkfun tutorial which does not contain an external oscillator. I rewired everything multiple times with no luck. I finally decided to try this circuit with an external 16Mhz oscillator and it worked:

http://upvector.com/atmega/

|improve this answer|||||
\$\endgroup\$
1
\$\begingroup\$

I had a similar problem with the TinyISP. I am not sure whether it was the TinyISP or a Linux configuration problem. I switched to the Atmel AVRISPMKII and have not seem the problem.

|improve this answer|||||
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.