0
\$\begingroup\$

I recently bought a tubescreamer PCB from Tonelab and soldered it together yesterday. I decided to go for Ts-9 model which requires (Ra=470ohm, Rb = 100kohm, Ca = unused) I tried to match all parts as close as possible .. some of the capacitors and resistors are a tad off (eg: 47pf instead of 51pf) but I figure it won't matter too much. All solder joints seem fine to me, no short circuits etc.

So anyway I power the circuit up and there's absolutely no output. I tried trouble shooting with the limited equipment I have (multimeter only)..

Checked all obvious things like battery, jacks, leads etc and they all seem fine. So I took a piece of wire and shorted the input and output together and I obviously got a clean signal coming through. I then followed on from the input going from 1st cap straight to output(still a signal) to 1st resistor (still a signal) but when get to transistor no output whatsoever so matter what terminal is used.

The voltmeter shows voltages at these points so I'm slightly confused. Also voltmeter shows no voltage across Ra but shows approximately 2 volts across 10k to left of it.

Can somebody please direct me in right area so I can fix this?

Schematic All parts shown

actual board layout1

Pcb layout

circuit

\$\endgroup\$
16
  • 1
    \$\begingroup\$ Hmm a link to the circuit maybe. I don't understand why you are shorting input and output. Do you have any test gear? A 'scope, multimeter, function generator? Did you use the same transistors? \$\endgroup\$ Commented Jan 8, 2015 at 17:26
  • \$\begingroup\$ just added schematic and requirements for each model.. i only have a multimeter unfortunately.. i thought by shorting the input at various points would lead me to problem(eg when no signal out of amp ) Im still a beginner at this so excuse my naivety :) \$\endgroup\$ Commented Jan 8, 2015 at 17:50
  • 1
    \$\begingroup\$ I suggest you start probing around to verify connections. The pad on the other side of that 1uF cap looks to be missing. You can jumper it to the 1K. Also check that the input isn't shorted to GND. And wiggle some parts very slightly to see if other pads are lifted. \$\endgroup\$ Commented Jan 8, 2015 at 19:24
  • 1
    \$\begingroup\$ @SpehroPefhany, According to his measurements there's only a 200 mV Vbe voltage drop... that doesn't seem like enough to me. (I did forget about the drop across the 510k ohm base resistor.) I don't know 9V batteries that well is 8.2V normal? (I loaded a new one with 1 k ohm and measured 9.2 volts.) To the OP, maybe check that the tantalum caps are in the right way. \$\endgroup\$ Commented Jan 8, 2015 at 21:08
  • 1
    \$\begingroup\$ @GeorgeHerold No tantalum caps in there- aluminum electrolytics though (and they're in right). 8.2V is a plausible voltage for a reasonably fresh zinc-carbon cell. Yes, 0.2V is too low, but if his meter is a few Mohms it could account for it since the emitter voltage will be stiffer. All seems close enough to me- looking for things that are really off since the parts look close enough. \$\endgroup\$ Commented Jan 8, 2015 at 21:18

3 Answers 3

2
\$\begingroup\$

Based on measurements in the comments, your bias voltages are pretty much as expected, so there is no obvious problem in the DC portions of the circuit. Both transistors are properly biased and the op-amp appears to be functioning.

Look for problems like open capacitors (or connections to capacitors such as lifted pads or open traces under that opaque solder mask), shorted AC signal path or similar.

\$\endgroup\$
3
  • \$\begingroup\$ sorry my bad it specifies Ra = 470 , Rb = 100k.. \$\endgroup\$ Commented Jan 8, 2015 at 17:45
  • \$\begingroup\$ Got it, a few meg input on the DMM would give those numbers. (A had to put it together on white proto board..kinda cheating?) \$\endgroup\$ Commented Jan 10, 2015 at 0:43
  • \$\begingroup\$ @GeorgeHerold 'taint cheatin' if it gives the right answer. 10M or 1M would seem more likely for a DMM input but the numbers don't work out. I just did it in my head. \$\endgroup\$ Commented Jan 10, 2015 at 1:21
2
\$\begingroup\$

I was thinking about this plowing my driveway tonight.

If it's still not working I might try replacing the first transistor. (maybe you hooked something up backwards and reversed biased it??)

What kind of multi-meter do you have?
If the AC voltmeter has a decent max frequency, you could use it to follow some AC signal around.

Perhaps your first job is to understand how the circuit works.

\$\endgroup\$
1
\$\begingroup\$

The "output side" of the 1k resistor near the input is directly connected to the base of the first transistor. If you can hear the audio signal when you connect the "output side" of that resistor to the output, but not when you connect the base of the transistor to the output, the problem is very likely to be the "output" solder joint of the resistor. As your measurements indicate, the DC current through the transistor is OK, so the 510k resistor, the emitter resistor and the collector connection seem all correctly soldered.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.