3
\$\begingroup\$

I'm using a MOSFET to switch a 24V, 15A load, with the gate input being a 500Hz PWM signal. However, this is causing the MOSFET to overheat and blow. Any suggestions would be appreciated.

R1 = 100 Ohm

R2 = 1000 Ohm

Q1 = IRL3103PbF (Vdss = 30V, Id = 64A)

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Why is R2 on the far side of R1? \$\endgroup\$ – Ignacio Vazquez-Abrams Feb 5 '15 at 19:30
  • \$\begingroup\$ This may be reusable: electronics.stackexchange.com/a/152134/8627 It is likely you aren't driving the MOSFET with high enough voltage. You do have to check if your MOSFET can withstand 24V on its gate though. \$\endgroup\$ – jippie Feb 5 '15 at 19:32
  • \$\begingroup\$ I do not like what figure 8 of the IR datasheet is saying... \$\endgroup\$ – Ignacio Vazquez-Abrams Feb 5 '15 at 19:35
  • \$\begingroup\$ The signal on the gate is the 3.3V PWM signal from the micro controller, not 24V. \$\endgroup\$ – Matt Feb 5 '15 at 19:36
  • \$\begingroup\$ @Matt: Microcontroller is being fed +5V, not 3.3V. \$\endgroup\$ – Dwayne Reid Feb 5 '15 at 19:44
7
\$\begingroup\$

Just for conduction losses, the power dissipation in the MOSFET could typically be \$I^2 \cdot R_{ds(on)}\$ or about 5.4W at Tj = 120°C, assuming 4.5V drive, which your 5V micro should be providing. At only 500Hz the switching losses should not be too bad even with a 100R gate resistor, but they can still add.

You need a fairly large heat sink or a fan to dissipate this amount of heat. Without a heat sink it will quickly overheat and destroy itself.


Edit: As Will Dean pointed out in a comment below, you can tell you've got a problem by looking at the thermal resistance junction-to-ambient (that's with no heat sink) from the datasheet.

enter image description here

The temperature rise above ambient would be 5.4W times 62 or 334°C, so in excess of 350°C with a 25°C ambient. That's way above the absolute maximum junction temperature rating, and the part will fail at some before it gets there.


If you already have a large heat sink, I would suspect that D1 is not doing its job. You do not give the part number, but it will have to dissipate quite a bit of power as well, so a Schottky diode is desirable.

\$\endgroup\$
  • 2
    \$\begingroup\$ I am not using a heatsink at all, perhaps this is the issue. \$\endgroup\$ – Matt Feb 5 '15 at 20:18
  • 2
    \$\begingroup\$ That is the issue! you need to pull the heat away from the FET or get a better FET. you are not switching that fast so change it for one with a lower Rds_on \$\endgroup\$ – JonRB Feb 5 '15 at 20:20
  • \$\begingroup\$ @Matt Note that the losses increase with junction temperature so it gets worse and worse as it heats. \$\endgroup\$ – Spehro Pefhany Feb 5 '15 at 20:25
  • 2
    \$\begingroup\$ Just to underline this point, the junction-to-ambient thermal resistance is in the datasheet at 62C/W, which is >300C at the power levels being discussed here. \$\endgroup\$ – user1844 Feb 5 '15 at 21:45
3
\$\begingroup\$

How hi is your uC current driving capability? If I am correct <20mA, whici is pretty low to turn on that MOSFET fast enought. The device might be heating up on the switch on/off periods. In orther words the MOSFET turn on/off time is pretty hi, the gate capacitance is charged too slow due to uC limited current out capability.

If that is the case, try to put a NPN + PNP (2N2222 + 2N2907) pair of transistors in totem pole config to drive the MOSFET, ie poor man's MOSFET driver.

Make the gate resistor as low as possible (), and power the totem pole from 24V.

Some simple numbers: from datasheet MOSFET input C=1.65nF, Rg=100 ohm 5Tau = .8us you drive it at 500Hz ... that means the total time spent in switching from on->off and off->on is alt least 1/1000 of the time. This is the time where the most losses occur.

\$\endgroup\$
-1
\$\begingroup\$

What is your physical layout? R1 needs to be right at the gate of the FET. Your 24V negative lead needs to be right at the source lead at the FET. Short lead from the FET source lead to the microcontroller ground pin.

In other words, treat the FET source lead as the star point connection for the 24V power supply and the rest of the circuit.

My thought is that the FET is oscillating.

FET specs look good: it is pretty much fully enhanced with Vgs higher than 4V

Other things to try:

Drop the PWM frequency and see if the FET still get as hot. If so, reduce R1 down to 22 Ohms.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.