0
\$\begingroup\$

I have a situation that just baffles me here...

I bought these cheap XY-MK-5V RF receivers with FS1000A transmitters. I fitted the receiver to an Arduino UNO connected to an 8-channel relay board, ready to go. The transmitter is attached to an Arduino UNO that would be connected to a home automation control system of some sort.

The transmitter has a single-core 17.2 cm insulated wire attached as an antenna. Same goes for the receiver, except that I accidentally pulled of the insulation and now it's just a single-core 17.2 cm "naked" wire. I use RadioHead (successor to VirtualWire) to handle the comms between the RF units.

And suddenly the receiver just stops working. Here's how it went:

  1. Tested Arduino-to-Arduino transmission using VirtualWire, it works.
  2. Tested Arduino-to-Arduino transmission using RadioHead, it works.
  3. Boosted transmitter operating voltage to 12V to increase range, it still works. (I used a XTW-SY-8 unit here)
  4. Modified transmitting Arduino to act as MQTT client (I also added an Ethernet shield at this point), and tested sending messages via MQTT broker installed on my RaspberryPi unit; it still works.
  5. I modified my MQTT broker to be a little bit more secure by adding a username and password, it still works.
  6. I installed OpenHAB on my RaspberryPi, configured some stuff, and got it to send messages via my MQTT broker. It FAILS! Note: The MQTT message topic, format, and content, are exactly the same.
  7. I went back to sending direct messages from MQTT without using OpenHAB, and it still won't work.
  8. I tried reprogramming the receiver Arduino, still won't work.
  9. I tried switching the receiver unit with a new one, and it still won't work.

Has anyone ever experienced the same thing? I'm really baffled here. Both the receiver and transmitter is in my room, about 5 feet apart from each other, if that matters.

I'm really out of ideas, and any help would be much appreciated.

\$\endgroup\$
  • \$\begingroup\$ Well, they are cheap... do you have any equipment that could detect if they are sending anything at all? Like a radio tuned at 433MHz or so.. \$\endgroup\$ – PlasmaHH Feb 10 '15 at 10:53
  • \$\begingroup\$ Indeed they're cheap, but I had them working. I had my prototype working and I could turn devices on and off remotely through my RaspberryPi's console. All I did was step it up to use openHAB and everything fell apart. I don't know what went wrong. \$\endgroup\$ – rad Feb 10 '15 at 11:02
  • \$\begingroup\$ I once got a bunch of LM2596 based buck converters. They all worked fine for a month or so, and then suddenly nada. What went wrong? Well, they were cheap... \$\endgroup\$ – PlasmaHH Feb 10 '15 at 11:05
  • \$\begingroup\$ You need to work your way all the way back to step #1 in order to determine exactly what changed between "working" and "not working". And can you define "won't work" a little more explicitly? Are you still seeing bits of any sort on the connection between the receiver and the Arduino? \$\endgroup\$ – Dave Tweed Feb 10 '15 at 12:40
  • \$\begingroup\$ Found it! Same experience with @PlasmaHH, my voltage converter decided it's time to go dead. Lesson learned: don't expect much from cheap stuff. Thanks a lot guys :) \$\endgroup\$ – rad Feb 11 '15 at 18:03
1
\$\begingroup\$

I did what Dave Tweed suggested: retraced my steps back to #1, and it still doesn't work. So I got curious and checked my voltage converter, which turned out to be dead. Replaced the XTW-SY-8 unit and I'm back on track.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.