1
\$\begingroup\$

I am attempting to make an LED light up using a capacitor.

My approach: I am attempting to connect a switch, capacitor and LED in series. My assumption is that when i press the switch the capacitor will start charging. AFter i release the switch i expect the LED to light up for some brief amount of time.

Whats happening: As soon as i click on th switch and LED lights up for an instance and goes off. However, (after holding the switch for approx 10-15 secs) i let it go, the LED doesn't light up.

Below is what the circuit looks like. Any feedback on my approach, circuit or on whats happening?

NOTE: The arduino board is just being used to power the circuit.

enter image description here

\$\endgroup\$
1
  • 1
    \$\begingroup\$ You should add a resistor, and put the capacitor not in series, but negative side to ground and the positive side near the switch. So 5v->button->positive-capacitor+resistor->led->gnd \$\endgroup\$
    – Gerben
    Feb 14 '15 at 12:39
2
\$\begingroup\$

Try wiring your circuit this way to get the effect you were thinking about. Experiment with the component values a bit to see different timing changes and brightness levels, (just keep R1 over 100 ohm).

Pressing SW1 slowly begins charging C1. When SW1 is released C1 discharges mainly through D1 & R1 lighting the LED. (Some current also discharge through R2 but much less.)

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
1
  • \$\begingroup\$ @caveman - Done \$\endgroup\$
    – Nedd
    Feb 15 '15 at 13:19
1
\$\begingroup\$

What's happening is what could be expected.

When you press the button the capacitor charges through the LED, and quickly, because you don't have a series resistor to limit the current. Once the capacitor voltage is a couple of volts (the LED voltage) below Vcc charging stops and the LED goes out. Add a series resistor to slow down the charging of the capacitor. The current will be limited to a safer level for the LED too.

When you release the button there's no longer a closed circuit, so there can't be any current. And no current means no light.
This isn't easy to fix. When you release the switch the capacitor should act as the current source, but the LED is the connected backwards, and won't light.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy