1
\$\begingroup\$

I'm creating a shield for arduino and to avoid recreating it in future, I created its base as component(both schematics and pcb) and only added arduino header pads in it. Everything is just working fine except in PCB designer when I put any other component inside the shield component, then both components gets green(error). Which is very correct behavior though. But I want other components to be inside as its a shield.

I even set shield component height to 15mm. But still error is not going away.

enter image description here

Edit (inserted 3D screenshot) : enter image description here

How can I make shield component allow to have other component inside ?

\$\endgroup\$
  • \$\begingroup\$ Can you show the 3D view of it and also the exact type of violation (is it a component clearance violation you're seeing)? \$\endgroup\$ – Tom L. Feb 22 '15 at 19:05
  • \$\begingroup\$ 3d screenshot added, I think violation type is collision ? \$\endgroup\$ – xmen Feb 23 '15 at 1:38
  • \$\begingroup\$ I think I found it when run Design Rule Check. It seems to be Component Clearance Constraint Violation. \$\endgroup\$ – xmen Feb 23 '15 at 1:56
  • \$\begingroup\$ Short answer because I don't have time to write at the moment: You need to create a 3D body for the component. Basically, if you don't explicitly define a 3D body for a part, altium just uses a rectangle for collision detection. Since in this case, the board outline is part of the component, and you expect to place stuff in that outline, you need to create a 3D body in the PCB component and (probably) place it over just the connectors (the locations where you can't put actual components). \$\endgroup\$ – Connor Wolf Feb 23 '15 at 2:06
  • \$\begingroup\$ There's also a setting somewhere to choose whether to do 3-d collision detection or not. Not at work so I can't say exactly where it is. \$\endgroup\$ – The Photon Feb 23 '15 at 3:04
0
\$\begingroup\$

You need to create a 3D body for this. May be the the supplier of the U-shield could provide a step model of it.

\$\endgroup\$
0
\$\begingroup\$

Note: This was written for Altium 19.0.12 (latest at time of post). It should also work for previous versions, although there may be some visual changes.

This is caused by a component clearance constraint violation.

Component Clearance Constraint

You can add another rule that applies to the shield footprint with the minimum height set to 0.

Open the PCB Rules and Constraints Editor under Design->Rules, and navigate the tree on the left of the new dialog window to Design Rules->Placement->Component Placement. Right click on Component Clearance and select "New Rule" Creating a new rule

Configure the new rule so it applies when the first component matches a component with the designator for the shield footprint, and where the second object matches any component. Set the vertical clearance mode to "Specified" and set the minimum horizontal and vertical clearance to 0. Configuring the clearance constraints

Apply the changes before closing the window. Check that your new rule has a higher priority than the original clearance rule by clicking on the Component Clearance section in the same PCB Rules and Constraints Editor window that you've been working in (visible in the second picture).

Clearance constraint violation fixed

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.