3
\$\begingroup\$

I have a footprint file for a component (.mod). There doesn't seem to be an option to import it though. How to do it?

Also the left-hand menu here doesn't seem to do anything.

\$\endgroup\$
  • \$\begingroup\$ I'm interested in knowing this too. I'll try to include the library and if I found any solution will post in here. \$\endgroup\$ – Luis Diaz Mar 11 '15 at 19:19
  • \$\begingroup\$ In the PCB tool, open up the Module Editor. From there you can open the footprint and then save it into a library. (Yeah, it's not the most intuitive process.) \$\endgroup\$ – mng Mar 11 '15 at 20:19
  • \$\begingroup\$ @mng This is how to convert from .mod to .pretty. \$\endgroup\$ – Matt Jul 29 '15 at 21:44
2
\$\begingroup\$

You are in the right place when looking at the library table. Click Append Library and you get a new line in the table. Fill out the table with the location of your .mod file in the Library Path and make the Plugin Type = Legacy. Click OK

If you want to save changes to a library, you have to save it as a .pretty which is their new format. This is just a way to continue to use footprints you have already made. With the newest compiled source there is a wizard to add footprint libraries...I've never tried it.

\$\endgroup\$
1
\$\begingroup\$

Open CvPCB and Click on Preference->Option. This should show a window to import custom MOD file. Select your file and save the project.

P.S. remember to remove the Footprint filter if you don't see your footprints.

Screenshot of the process attached.

Step 1

Step 2

Make sure to remove footprint filter

\$\endgroup\$
  • 1
    \$\begingroup\$ It looks like that's an older version of KiCAD \$\endgroup\$ – W5VO Mar 12 '15 at 5:10
  • \$\begingroup\$ It is. Now they broke it. \$\endgroup\$ – user61143 Mar 15 '15 at 17:43
  • \$\begingroup\$ It's not broken it is changed. \$\endgroup\$ – Matt Jul 29 '15 at 21:42
0
\$\begingroup\$

I work on the latest release of kiCAD and I have to admit the library management is tedious but it's all part of the learning curve.

With the new library management system in the Footprint Assignment interface that you access through the "Run CvPcb..." button (were you're already), once you add the new library( I advise you to go through Append Wizard, because it's more user friendly for Win7) in order to change the Plug-in type there is a tricky and hidden drop down list that shows by default KiCAD. That's were you have to double-click. Most of the other libraries( .pretty extension) are either GitHub or KiCAD, depending on where you got your library.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.