3
\$\begingroup\$

After getting two modems (dev boards) Siemens TC35 and SIM900A I cannot get them to send SMS. From the research it seems that somehow SIM cards will not register to network. I bought three SIM cards from different networks currently operating in my location.

Commands to GSM module:

AT
OK
AT+CREG?
+CREG: 1,0
OK

Any hints?

EDIT:

All SIM cards have their pin security check disabled. All cards have been inserted into phone, tested for a call and tested to send SMS to another phone. Also all of them all full of credit.

EDIT2:

Just tested cards with GM862 module with same commands and all works fine (sending SMS works withut any issue)

EDIT3:

For reason unknown to man kind, and all the frustration I've decided to run TC35 without SIM card, and add SIM card in the process of running.Running AT+CFUN=1 , and then trying to sens SMS proved to work. I've then unplugged TC35 from power and then connected it back and now it works normal. Only god of electronics and mights of circuits know what the hell is going on there.

So for know only SIM900 still doesn't work.

\$\endgroup\$
  • \$\begingroup\$ Been a while since I've used a TC35 but I vaguely remember you might need to use a AT+CFUN=1 command before they'll register on the network. \$\endgroup\$ – PeterJ Mar 5 '15 at 6:25
  • \$\begingroup\$ Do AT+CEER or AT+CMEE commands tell you anything interesting? \$\endgroup\$ – brhans Mar 5 '15 at 13:39
  • \$\begingroup\$ Respond for AT+CMEE : +CME ERROR: 3 \$\endgroup\$ – user505160 Mar 5 '15 at 13:48
  • \$\begingroup\$ Does using GSM modem involves anything more then inserting sim and powering up to register on a network? because GM862 worked that way without any problems, are there any init commands needed in the process itself for some other modules, like this one? \$\endgroup\$ – user505160 Mar 5 '15 at 13:50
  • \$\begingroup\$ Operator selection (AT+COPS) maybe? \$\endgroup\$ – pjc50 Mar 5 '15 at 15:45
4
\$\begingroup\$

Solution is to reflash SIM900A with SIM900 software and it works like a charm.

Here is the page that shows the solution.

Flashing is no trickery, just a right sequence of operations, there is detailed instruction for arduino-like approach, my way required just a few major steps:

  1. Power up your SIM900A module to respond to AT commands in auto-baud mode (AT+IPR=0). It means you must wire powerlines, do power-on sequence with PWRKEY etc.
  2. Setup flashing tool — connect it to SIM900A, set default speed of 460800 baud, choose firmware to flash from unpacked RAR file, select “don’t check file name” check-box and press “start download” button to see “Power On/Reset Target” message.
  3. Short NRESET (pin 16) to GND for a moment. Right after it reboots flashing tool will start pushing data.
  4. When flashing ends with “Download complete” power off SIM900A module. Note that reset will not work, disconnect power line and start power-on sequence once again.
  5. Voila! It works now as expected. PIN accepted, logged in to network and test text message successfully sent to my smartphone.

Thanks everyone for helping out!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.