Just received my first ESP8266 wifi module with some excitement. However I've been unable to fully communicate with it. I have connected the module to my computer via a usb to serial cable and I'm power the module via a separate power supply (3.3v).

After powering the module up I receive the following information (via PuTTY or and Arduino serial monitor window):

[Vendor:www.ai-thinker.com Version:]


I have tried sending various AT commands e.g.


But I get no response. Using ctrl+m and ctrl+j in putty didn't help either.

Please see my youtube video if its helpful: https://www.youtube.com/watch?v=RvasOuHuWDc

  • \$\begingroup\$ Check your TX line (the one that is transmitting the data from the computer/micro to the module) \$\endgroup\$
    – Eugene Sh.
    Mar 23, 2015 at 21:07
  • \$\begingroup\$ What kind of USB-to-serial, not an USB-to_RS232 I hope? Do you get the echo of the characters you type? \$\endgroup\$ Mar 23, 2015 at 21:13
  • \$\begingroup\$ is there anything else on the serial line that could be loading it down? Are you sure you are doing your AT commands properly? \$\endgroup\$
    – KyranF
    Mar 23, 2015 at 21:19
  • \$\begingroup\$ my Xbee for example needed me to send "+++" first, and then it goes into AT command mode. From then on, I use "ATID\n" for example to ask it what it's PAN ID is. Make sure you include (or not) appropriate new-line characters if needed, my Xbee module expects new line characters after each AT command. There is also a guard time between each AT command (1 second for me). Check that your wifi module has not got all these annoying AT command things, something like that could be the issue \$\endgroup\$
    – KyranF
    Mar 23, 2015 at 21:21
  • \$\begingroup\$ Are you using Both NL & CR setting in Arduino serial monitor? \$\endgroup\$
    – alexan_e
    Mar 23, 2015 at 21:22

3 Answers 3


Thanks for all your help. The solution was modify the line ending option at the bottom of the Arduino serial console to send both CR and LF. Still not got PuTTY configured but have something to test now. Thanks :)


I recently started "playing" with this module, and there are a few things to keep in mind:

And of course, have fun!


This worked for me:


You can enable/disable crlf in screen comfortably.


Not the answer you're looking for? Browse other questions tagged or ask your own question.