1
\$\begingroup\$

I just bought the peltier and its of 60W 12V 5A and its maximum capacity is of 90 watt power. I am using my Pc power supply which have ability to provide 12V and 15A maximum. I connect to that lead and check the current drawing using multimeter and my peltier only drawing 1.5A at start and then keep decreasing until 1A.
However peltier seems to be working because the colder side getting colder but not enaough because its only drawing 1 A. However it have capacity to draw maximum 6A.

To test it further, I connect it with my 12V 80Ah battery and same result. Not sure why it is doing that.

For further investigation I connect two peltiers (Connecting red wire to red and black wire to wire) by connecting red wire to the postive terminal of the power supply and black to the negative and then I check the current draw and its drawing 3A and then keep decreasing slowly slowly.

\$\endgroup\$
  • 2
    \$\begingroup\$ Is it attached to a big heat sink or just hanging loose in the air? \$\endgroup\$ – George Herold Mar 30 '15 at 16:34
  • 3
    \$\begingroup\$ You have to remove the heat from the hot side for the cold side to get colder. That will make it draw more current. \$\endgroup\$ – Matt Mar 30 '15 at 16:49
  • \$\begingroup\$ Thank you for your reply to both George Herold and Matt Anderson. I have attached the peltier with big heat sink. \$\endgroup\$ – Ali Hasan Mar 30 '15 at 17:06
  • \$\begingroup\$ Matt Anderson, are you sure that peltier works in this way that reduce the heat and then it will draw more current ? \$\endgroup\$ – Ali Hasan Mar 30 '15 at 17:07
  • 1
    \$\begingroup\$ Was it one of the cheap ones from ebay or amazon? It happens that they send you ones with different specs than what you ordered when they ran out of those you ordered.. \$\endgroup\$ – PlasmaHH Mar 31 '15 at 8:47
5
\$\begingroup\$

For current draw, the peltier just looks like a resistor. However, as it heats up that resistance increases. So in order to get maximum current draw you need to keep it as cool as possible.

1.5 Amps still seems a little low, but these things are notorious for being specified poorly. All it really does is move heat, the end result being a temperature difference between the two sides. So the colder you keep the hot side, the colder the cold side will get.

Thermoelectric Cooling

The current is linear with supply voltage. If you supply a higher voltage you will get a proportionally larger current and the temperature difference between the two sides will increase(not proportionally though). If you exceed 80C or so on the hot side, your device will start to degrade. These are just rules of thumb not knowing your exact specifications.

\$\endgroup\$
  • \$\begingroup\$ Thank you very much for your reply. I just do the testing again with little changements, I dip the heat sink to the water and now the hotter side is not the hot as its temperature was only 45 degree centigrade and colder side is of 5 degree centigrade and the current drawing was 1.5 amp and the voltage was 11.14. \$\endgroup\$ – Ali Hasan Mar 30 '15 at 20:01
  • \$\begingroup\$ Yes as I also thought that 1.5 amps is still low, it should take at least 3 amp. What you think that why this is happening ? Can the peltier is faulty ? As I have purchased 2 petliers and both have same result. But if the petliter is faulty then how the cooling side getting colder ? \$\endgroup\$ – Ali Hasan Mar 30 '15 at 20:03
  • \$\begingroup\$ Or it is due to the 11.14v ? Thank you for your time. \$\endgroup\$ – Ali Hasan Mar 30 '15 at 20:04
1
\$\begingroup\$

Sorry for resurrecting this old thread. But I had the exact similar situation few months back and this is what solved for me. Hope this might help someone in future.

1.A good quality high current 12V source i.e, what the OP has used here is good SMPS or Lead acid battery.

  1. This is what solved my issue. A good quality Thermal paste with big heat sink and a good 12V 1A fan to drive heat out quickly. This one step brought my cold side temp from 5C to -4C and current draw was now like 4.5A initially, then quickly dropped till it reached 2.8A to 3A and stabilized.

Also never run the peltier above 12V for longevity of the module.

\$\endgroup\$
-1
\$\begingroup\$

I had a similar issue and found a solution that worked for me.

Power connectors for typical computer psu's have multiple wires for the same voltage (e.g. multiple +12V ports). So even if the rail can draw 15A maximum, it won't through one wire connected to one +12V port. You'd have to wire multiple +12V wires together from the connector to get more amps. I found out about this here:

http://www.playtool.com/pages/psuconnectors/connectors.html

Manufacturers don't use just one beefy (think 10 gauge) wire for +12V to the connector because power losses would just be too high. Also, they don't want to run too much current through any one of the several +12V wires in the connector because they don't want to melt the wire (they're probably 18 gauge).

I'd try wiring two +12V ports from the same connector to a beefy (10 gauge) wire for power and then two of the GND ports to a beefy wire and give that a whirl (connect them to the peltier). If you use all three +12V ports, use three GND ports, etc., all with "beefy" wires to prevent things from melting.

(Your battery may also have a current limit of 3A. The current draw will depend on the load, but most constant voltage regulated power supplies have a current limit. Just google benchtop power supplies and you'll see a 0-30V adjustable voltage supply will only operate up to 5A. On the same note, a 0-30A adjustable current supply with only operate at/up to a given volage)

Granted, my solution really only works for testing. You'd be best getting a dedicated power supply for your peltier (like a Mean Well). If your psu is loaded up with other stuff, you might hit the 15A maximum sooner than you think.

\$\endgroup\$
  • \$\begingroup\$ From the Molex Connector wiki page: Max. voltage: 12 V, Max. current: 11 A/pin (30 °C rise) \$\endgroup\$ – ppeterka Aug 28 '16 at 12:47
  • \$\begingroup\$ (was too slowly editing prev. comment): While the 11A capability of the connector is usually not near to be fully used, a few Ampers should not be an issue - think of old time FH 5,25" drives. The rating for AWG 18 is also 16A for chassis wiring (source) \$\endgroup\$ – ppeterka Aug 28 '16 at 12:55
  • \$\begingroup\$ Ah dang, really?! I'm stumped :/. My last bet is to try to run the tec at 15.4V. My data sheet (tec1-12706) says voltage at max current is 15.4V. Like Matt said, current draw and voltage are linearly related, and better cooling = higher current draw. With water cooling and 1 voltage pin, I drew 2.6A. Even with 15.4, I bet I won't get much higher current draw, but I'll let you know if I do (I have to use my variable voltage psu). Did you ever find a solution? \$\endgroup\$ – A. Hendry Aug 30 '16 at 2:51
  • \$\begingroup\$ I'm also having trouble repeating my success with the two +12V pins...so my solution might've been mallarky :/. \$\endgroup\$ – A. Hendry Aug 30 '16 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.