4
\$\begingroup\$

I recently purchased an Arduino Ethernet shield, plugged it on top of my Arduino Uno and loaded up the WebClient/WebServer sketches that comes with the Arduino 0022 IDE, but I could not get it working.

I've tried a number of IP address configurations, played around with the router, etc., but to no avail. I can't ever ping the device, and never see it appear on the router.

If the 'link' LED on the Ethernet shield is not lighting up when I plug into the Ethernet jack, is this a sign of a faulty board? Or is there some other diagnostic test I can try to verify the board is OK?

I'm thinking the board is the problem and will try another one.

\$\endgroup\$
  • \$\begingroup\$ I went and picked up a freetronics ethernet-ten (freetronics.com/products/etherten) from jaycar this afternoon. I now have nice flashing lights on the ethernet port :-) \$\endgroup\$ – brodie Jul 8 '11 at 5:59
  • \$\begingroup\$ I have the same problem. Where did you buy the first (faulty) shield from? \$\endgroup\$ – Dojo Jan 24 '13 at 18:01
  • \$\begingroup\$ I got my board from LittleBird Electronics (littlebirdelectronics.com) in Australia. They happily replaced it for me and all good now \$\endgroup\$ – brodie Jan 25 '13 at 3:40
1
\$\begingroup\$

If the LED is not lighting up, there's definitely a problem.

I'd check the power, try a different Ethernet cable, and - if possible - a different board.

\$\endgroup\$
  • \$\begingroup\$ thanks for confirming my suspicion. Yes, I've tried using both USB power and the adaptor power as well as many other cables. I'll get another board and hopefully have more luck. \$\endgroup\$ – brodie Jul 7 '11 at 22:44
  • \$\begingroup\$ i got another board and everything worked as expected \$\endgroup\$ – brodie Jan 25 '13 at 3:39
3
\$\begingroup\$

You can make a loopback cable to test if the ethershield is working. Basically if you plug this in it should show "link" in other words green light.

No "link" then there is no communication on that port.

No RX/TX - cant tell which. This will not damage anything.

enter image description here

enter image description here

enter image description here

\$\endgroup\$
  • \$\begingroup\$ thanks - i'll try making one of these loopback plugs and see how it goes with the board \$\endgroup\$ – brodie Jul 7 '11 at 22:42
2
\$\begingroup\$

If your W5100 Ethernet shield is a PoE-ready version, it is not compatible with the Arduino Uno.

You can try:

It works!

\$\endgroup\$
  • \$\begingroup\$ I have a W5100 and it worked for a long time with my UNO board, but now it doesn't. \$\endgroup\$ – George Nov 15 '15 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.