5
\$\begingroup\$

Recently I've got myself a couple of ESP8266 modules. I flashed the latest NodeMCU firmware, and tried to communicate with a PC using UART.

Here's how I wired my circuit: breadboard schematic

Using a simple USB to Serial interface or FTDI I tried to communicate with the ESP8266 with ESPlorer v0.2.0. I opened a Port on baud 74880 because It's the only successful one for some reason.. Here's the log.

ets Jan 8 2013,rst cause:2, boot mode:(3,6)

is the only 'reasonable' output from the ESP8266, sometimes I get

Fatal exception(0):

from ESP8266 module but It's very rare.

I've been struggling with this for a good week now. ESP8266 is very unpredictable to work with.. For every command I send I get garbage output or that ets Jan...

Any good ideas? Maybe the FTDI can't draw enough current?

\$\endgroup\$
5
  • \$\begingroup\$ if you're getting gibberish from the FTDI, it's because the baud rate is wrong. \$\endgroup\$ – kolosy Apr 15 '15 at 20:29
  • \$\begingroup\$ also - if you're using a SparkFun FTDI board, they come in two flavors - a 3.3V and a 5V. make sure you're using the right one for your chip. \$\endgroup\$ – kolosy Apr 15 '15 at 20:31
  • \$\begingroup\$ @kolosy I tried all baud rates, 74880 is the least troubling one ( sometimes I get 'reasonable' data ). I am using the 3.3V one hope you can see the big font in the picture up there. :) \$\endgroup\$ – Muhamed Krlić Apr 15 '15 at 20:32
  • \$\begingroup\$ yes, i see the note, i'm just pointing out that it doesn't have to output 3.3 by default. \$\endgroup\$ – kolosy Apr 15 '15 at 20:35
  • \$\begingroup\$ @kolosy I encounter the same problem with other tools. Indeed, saw also a few times fatal exception(0) at 76880 or 74880. Flashing new firmware fails. Tried esptool.py on the RPi and ESP8266Flasher and Lualoader 0.87 on Windows 7. I bought it early, september/october 2014. Maybe a wrong factory firmware. Ordered new ones. My esp8266-05 works well, but not enough pins, only AT, and not flashable. \$\endgroup\$ – user76858 May 19 '15 at 10:08
10
\$\begingroup\$

You have two problems

1) The output you see (ets Jan 8 2013,rst cause:2, boot mode:(3,6)) is printed by the startup (bootloader) code. After that, the communication continues on a different baudrate (IIRC either 9600 or 115200 baud, depending on the firmware revision).

2) The 3.3V output of an FT232 can't deliver the current required by an ESP8266: not by a wide margin. Use a separate 3.3V supply. Probably the ESP8266 crashes due to too low voltage during or right after startup.

\$\endgroup\$
4
  • \$\begingroup\$ Wouldn't adding a 3.3k Ohm pull up resistor in serial be a good option to bring up the amperage for the ESP8266 to the needed 215mA at full broadcast? \$\endgroup\$ – user12242 May 19 '15 at 20:21
  • 1
    \$\begingroup\$ A pull-up resistor connected in series?? And NO, that wouldn't be a solution however you connect it. \$\endgroup\$ – Wouter van Ooijen May 19 '15 at 20:54
  • \$\begingroup\$ Guess your right about the resistor, it worked but wasn't very stable. However a 1000uF capacitor did the trick, no extra power source needed. Kind of feel like 1kuF is a bit over kill. Any suggestions on a better size? \$\endgroup\$ – user12242 May 26 '15 at 2:15
  • \$\begingroup\$ For this application (buffering for a long power draw) I would not consider 1mF big. In this situation I would try to find the minimum value that works and then I would (for production) take one at lesast 10 times as large. \$\endgroup\$ – Wouter van Ooijen May 26 '15 at 6:23
2
\$\begingroup\$

According to NURDSpace the requried power at full broadcase of 802.11b, CCK 1Mbps, POUT=+19.5dBm, is 215mA. therefore if my math is correct either a 1.5k Ohm or a 3.3k Ohm pullup resistor is required in serial to stablize the vcc signal.

From there one should try either 9600, 115200, or 57600 BAUD to communicate with the ESP8266 as discovered by electronicdragon.

A little further research on your firmware's version shows that the bootloader starts up in 76923 BAUD then shifts over to 115200 BAUD to listen for AT commands.

\$\endgroup\$
2
  • \$\begingroup\$ EDIT: since I do not have enough karam on EE.SE at this point to post more than two links; the link to the "further research" is vogelchr.blogspot.com/2014/12/… \$\endgroup\$ – user12242 May 19 '15 at 20:46
  • 1
    \$\begingroup\$ Confirmed today, got my esp8266-01 to work off a FTDI(CP2102) and only needed a single 1000uF cap(C1). C1 is taking in 3.3v(VCC) off the 3.3v out from the FTDI and is sharing a line with CH_PD and VCC (each pulled high). tx and rx are crossed between each chip. And finally GND(esp) to GND(FTDI). I have an older firmware (0018000902-AI03) so mine starts on 74880 Baud and then takes AT commands on 9600 Baud. So, check for communication at 9600/8-N-1 or 115200/8-N-1 for your serial port. \$\endgroup\$ – user12242 May 26 '15 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.