0
\$\begingroup\$

Quite sure it's a hardware bug, going to replace the chips 21-4-2015... We've got two 'identical' set-ups with the same code on it... but they both act different... (None works)

I'm currently working on a project involving a TRF7970A (SPI), so far I have managed to set up the SPI connection and read/write the registers. But I seem unable to create a RF field.

  • Project: RFID Reader
  • MCU: PIC18F66K22
  • Reader: TRF7970A
  • Problem: No RF field
  • Working: SPI connection (Reading/Writing registers)

It's quite hard to find any projects with this reader, which are clear on what to set the registers to and I'm hoping if anyone has experience with the TRF7970A.


The register values I set / think are needed are:

Chip Status Control Register (0x00)
Bit 5 = 1 (RF output active)
Bit 0 = ? (3V or 5V operation, tried both, could this damage the chip?)
          (I'm working with PIC (~3,3V) but source is LI-ION ~3,7V)
(This is compliant with an earlier project, in which it did work)

.

Regulator and I/O Control Register 0x0B
Tried Bit 7 = 1  (Auto-regulation)
Aswel as manual settings

I just see that in 3V mode VDD_RF goes from 2,7V to 3,4V and in 5V mode it goes from 4,3V to 5V. Is it possible that in 3,7V (LI-ION/Working voltage) The TRF7970A will not work?

For this moment, the ISO settings/ protocol etc don't really matter, I just want to get an RF field (measured with oscilloscope). So powering it with a Li-Ion (3,7V) is wrong? Or what register settings am I missing? The osccilator of the chip seems to be working fine.

schematic

\$\endgroup\$
  • \$\begingroup\$ If it's a hardware problem a circuit showing what you have got will be needed. \$\endgroup\$ – Andy aka Apr 20 '15 at 9:26
  • \$\begingroup\$ Added it, but it was working in another project. We ordered a replacement chip as this one might be broken when we resoldered it. Is there any way to check the functionality of a pin using a multimeter? Or well, the pin is not giving any output, while we think it should. But could also be because of the register settings? \$\endgroup\$ – Paul Apr 20 '15 at 10:13
1
\$\begingroup\$

Replacing the chip has worked! We're now getting an RF field...

Probably was a bad solder connection or broken chip.

\$\endgroup\$
  • \$\begingroup\$ These things are almost "undebugable"? As everything seemed fine. Is there a wat tot check solder connections or pin functionality (of a pin which software might nit work) \$\endgroup\$ – Paul Apr 22 '15 at 5:21
0
\$\begingroup\$

How can you expect an RF field to be produced - there is no antenna connected to the TX_OUT pin. The data sheet for the TRF7970A points to another data sheet that shows a typical antenna for the TRF7960A (a slightly different version): -

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I actually left the antenna away in the circuit so it's easier to see. I should've mentioned that, but I mean that there is no output on the TX_OUT pin \$\endgroup\$ – Paul Apr 20 '15 at 10:32
  • \$\begingroup\$ There is no excuse for not showing this vital bit of hardware!! \$\endgroup\$ – Andy aka Apr 20 '15 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.