0
\$\begingroup\$

I'm attempting to build a soundcard oscilloscope, but my computer doesn't seem to be reading the voltage on the audio jack plugged into it.

I'm using an Acer laptop (product ID 00179-60315-00598-AAOEM) running Windows 8.1. It has one audio port with a picture of a pair of speaker-headphones by it.

I think that I've configured "Microphone" and "Stereo Mix" to line-in modes by (1) unchecking their "use this device for playback" box, (2) turning "Microphone Boost" to zero, and (3) deactivating all extra sound effects. Both devices are set to their "2 Channel, 16 bit, 44100 Hz (CD-Quality)" mode. Sometimes when I plug the jack from the oscilloscope probe in, before I turn the power to the signal on, "Audio Recorder" spikes up with a little green bar for a second, making me think that the things really are configured correctly. It only seems to do this when "Microphone" is in use, though -- not "Stereo Mix".

I've also tried plugging the probe into the microphone jack on a local Windows desktop computer and making the same changes to "Microphone", but without luck. "Audio Recorder" shows a constant little green bar, but it is not affected by the signal fed into the probe, or even if the probe is plugged in.

The oscilloscope-probe-to-be is very nearly the same as that described in the link above. It uses a 1/8" stereo plug, with one common- and two signal-sections on the plug. The wire connected to the section at the very tip, however, doesn't seem to be making a very good connection, so only the middle section actually gives a signal out. I'm reasonably sure that it works. I've hooked the probe up to a sinusoidal test signal and looked at the voltage on the plug's middle section with a real oscilloscope, and it matches pretty closely with what's coming out of the function generator. I've been trying signals of around 200 mV between 10 Hz and 100 kHz or so. It may be noted, however, that my function generator might be producing a really, really crappy signal.

So again, my problem is that my computer doesn't see anything when I plug the probe in. I'm looking both through "Audio Recorder" and "Soundcard Oscilloscope". I was thinking that the problem might be that the stereo jack's forward output isn't working, but "Soundcard Oscilloscope" is supposed to look at both outputs, I think, so I don't know anymore.

I'm not very sure that Electrical Engineering is the right place it put this question, but it was focussed around an electronics project of mine and I don't know where else on Stack Exchange it would go. A migration to a more suitable site would be okay, however.

Many thanks for any advice on this; I'm pretty much out of ideas at the moment. I would gladly post more details or upload pictures and stuff on request.

\$\endgroup\$
2
\$\begingroup\$

I'm not familiar with your particular laptop but if it has only a single audio jack, it's most likely intended for headphones or powered speakers.

However, the fact that you occasionally see something on the audio recorder application when you plug in makes me want to suggest something;

Try plugging in a earphones / microphone from a cellphone. I'm thinking specifically of a Samsung cellphone - I'm familiar with them.

Now see if you can see anything on the audio recorder application when you speak into the microphone.

What are need to find out is if your single audio jack has a mic input. Thus should help you find out.

\$\endgroup\$
  • \$\begingroup\$ This is exactly the problem with my dell laptop. It has a pure headphone port and a headset port. A microphone does not work in the headset port, it must be a headset with a 4-terminals-jack. There, the ground terminal is divided into mic-in and GND. This means you will have a mono signal only. But you also may want to use the stereo out, as the software also contains a signal generator. Btw: software was written by my professor. Glad to see it's used here. \$\endgroup\$ – sweber May 9 '15 at 6:52
  • \$\begingroup\$ Just to make things interesting note there are 2 "standard" 4 pole trs connection. one where the ground is the shoulder of the connector and the mic is the next ring. the other is ring 3 is ground and the shoulder is the mic... iknow my lenovo laptop doesnt work with my samsung headset... \$\endgroup\$ – Spoon May 9 '15 at 13:06
  • \$\begingroup\$ Thank you! I do not have access to a four-pole plug at the moment, but I will make aquiring one a priority. Also, I tried looking into the jack on my computer, and it does appear to have four contacts . . . two of them are rather close together, so they might connect to same thing, but there are definitely four contacts. Also, I tried plugging the probe into a nearby desktop computer's microphone jack, and it still didn't appear to work \$\dots\$ no idea if this provides any insight. Anyhow, thank you! I now have something to investigate. \$\endgroup\$ – Jordan May 9 '15 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.