3
\$\begingroup\$

Altera Quartus, as most other EDA tools, allows users to use their favorite editor, instead of the built-in editors. For Quartus, this feature can be activated in Tools > Options > Preferred Text Editor.

When I fill in stuff in this dialog, Quartus does not store the data. The old editor is still used, and when I come back to the dialog, the default value is still there ("Quartus II Text Editor" is selected).

Have any of you encountered this? What am I doing wrong?

\$\endgroup\$
  • 1
    \$\begingroup\$ Does anyone know where Quartus stores these settings? (there might be a problem with permissions?) \$\endgroup\$ – Philippe Jul 19 '11 at 13:47
3
\$\begingroup\$

It turns out that things are stored in ${HOME}/.altera.quartus/. This directory was owned by root on my system, probably because I had executed quartus with root privileges before.

I removed the directory and everything was fixed after that.

\$\endgroup\$
  • 1
    \$\begingroup\$ chown user.group -R is usually the solution for this kind of problems. \$\endgroup\$ – Johan Jul 20 '11 at 19:30
  • \$\begingroup\$ @kurtuk the systems has requires a 24 hour delay between posting my own answer and accepting it. It is accepted now. \$\endgroup\$ – Philippe Jul 21 '11 at 19:41
2
\$\begingroup\$

I didn't have a problem setting it to use the PFE text editor and PFE was used when I created a new VHDL file to test it. I then reverted to the standard Quartus II editor.

The Altera forum is the best place for questions like this.

\$\endgroup\$
  • \$\begingroup\$ you're probably right about asking this stuff on the Altera Forum. Thanks. \$\endgroup\$ – Philippe Jul 21 '11 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.