8
\$\begingroup\$

I upgraded to Eagle 7 a couple of days ago the the scroll behaviour seems to have changed. Using a two finger scroll on a mac trackpad I used to be able to pan around in Eagle 6 but using Eagle 7 this has now become zoom in and out.

Has anyone else experienced a change like this or does anyone know how to revert the behaviour?

\$\endgroup\$
  • 1
    \$\begingroup\$ I would think Eagle has a support page or forums which would be a more appropriate/faster way of getting your answer... \$\endgroup\$ – I. Wolfe May 18 '15 at 14:47
  • \$\begingroup\$ Perhaps, I followed previous similar questions which led me here and I didn't fancy registering on another site so I tried my luck. I switched back to version 6 which has solved my problem for now. \$\endgroup\$ – ArthurGuy May 18 '15 at 18:46
  • \$\begingroup\$ How did you manage to get a version 7 license a couple of days ago? \$\endgroup\$ – Olin Lathrop Apr 21 '17 at 15:01
6
\$\begingroup\$

Had the same problem. Fortunately, it's an easy fix!

Options > User Interface...

  1. Set mouse wheel zoom to 0.
  2. Turn Legacy mouse wheel mode off.

Enjoy!

\$\endgroup\$
  • \$\begingroup\$ you awesome !!! \$\endgroup\$ – b-ak Oct 5 '17 at 12:07
1
\$\begingroup\$

The solution for me on Eagle 7.6.0 on Macbook was typing SET Interface.UseCtrlForPanning 1 into the command field (near the top of the window). The command key along with trackpad click-and-drag now pans. I found this solution here.

My symptoms were the scrollbars were missing and nothing would pan the window. Two-finger pinch would zoom in and out, but no panning.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.