1
\$\begingroup\$

I've been messing around with the Nucleo with mbed for the last week or so, but I'm keen to get out of that and back into some lower level C to give me more flexbility.

I have the problem, however, where I can't detect the ST-link on the nucleo to program it. I don't know if it's just because my PC only sees it as a storage device, or I'm doing something else wrong.

Has anyone else successfully programmed the nucleo outside of the mbed IDE after using it like that?

\$\endgroup\$
  • \$\begingroup\$ You need software that supports the ST-LINK/V2, such as the Rowley CrossWorks package. It worked OK when I tried it. \$\endgroup\$ – Leon Heller Jun 1 '15 at 11:00
  • \$\begingroup\$ I usually use Keil uVision without any issues. I was wondering if there was something special I had to do with the nucleo since it's mbed enabled. \$\endgroup\$ – Sensors Jun 1 '15 at 11:02
  • \$\begingroup\$ I didn't have to do anything. \$\endgroup\$ – Leon Heller Jun 1 '15 at 11:33
  • \$\begingroup\$ Turns out it was complaining when I didn't program under reset. \$\endgroup\$ – Sensors Jun 2 '15 at 17:58
0
\$\begingroup\$

Turns out that the Nucleo likes to connect under reset, maybe something to do with the mbed bootloader.

This can pretty easily be resolved by changing the settings of the st-link debugger in uVision to connect under reset.

st-link settings for nucleo programming in uVision

On a side note, if you create a new project using STM32CubeMX, it also tends to set the port as 'JTAG' rather than 'SW'.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.