0
\$\begingroup\$

I have a JDM programmer for pic micro-controllers, but it came with RS232 port. I have bought a "RS232 to USB" cable with its driver for Windows only and I use Xubuntu 14.04 LTS.

I have tried dmesg and lsusb, it shows that the cable is connected. But when I try to burn hex file to the programmer, it gives me this output:

PICPgm Development Programmer Version 2.8.1.0
http://picpgm.picprojects.net
Copyright 2002-2014 Christian Stadler (picpgm@gmx.at)
(built on Dec 29 2014 at 22:32:45)
==================================================================

Autodetecting Programmer ...

Warning: Unable to open parallel port I/O driver!
         Installing driver requires admin/root rights!

Error! PIC Programmer not found! Check connection!
\$\endgroup\$
  • 2
    \$\begingroup\$ "Unable to open parallel port" - Are you sure this is a serial interface? According to this website you may need to manually configure the software to use the virtual COM port provided by your RS232 converter. Choose Hardware => Hardware Selection/Configuration from the UI. \$\endgroup\$ – Roger Rowland Jun 2 '15 at 6:25
  • \$\begingroup\$ I have downloaded my software from this site and it says that Linux has only CLI \$\endgroup\$ – Nasser Jun 2 '15 at 6:45
  • \$\begingroup\$ One problem I see is that it is trying to autodetect your programmer and it assumes that you have a parallel connection. You need to stop it autodetecting and tell it to use the correct serial port. You need to read the documentation to find out how to do that. \$\endgroup\$ – Roger Rowland Jun 2 '15 at 6:51
  • 2
    \$\begingroup\$ Actually, you're probably not in luck. Read this FAQ - "Unfortunately, the JDM programmer does not work with a USB to COM port converter" \$\endgroup\$ – Roger Rowland Jun 2 '15 at 6:53
  • \$\begingroup\$ Thx it helps me I will buy new USB programmer \$\endgroup\$ – Nasser Jun 2 '15 at 7:06
1
\$\begingroup\$

In ubuntu, regular users don't have permission to access the serial ports, you need to be root, use sudo or add your user to the "dialout" group.

\$\endgroup\$
  • \$\begingroup\$ I have tried and still have the same problem \$\endgroup\$ – Nasser Jun 2 '15 at 6:46
  • \$\begingroup\$ The program is not even attempting to use a serial API, so no, this won't help. \$\endgroup\$ – Chris Stratton Jul 13 '15 at 13:42
0
\$\begingroup\$

In addition to adding yourself to group dialout:

You may have brltty installed. It is a braille display deamon that on some Ubuntu versions is pre-installed and auto-starts. It has the nasty behavior of opening all USB serial ports and sits on them, effectively disallowing other applications to work with usb to serial converters.

You can get rid of it via:

apt-get remove brltty

\$\endgroup\$
  • \$\begingroup\$ Please note that from the history of the question and its responses, no attempt is actually access a serial port API is being made. \$\endgroup\$ – Chris Stratton Jul 13 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.