-1
\$\begingroup\$

I want to display my output on 3 seven segment displays, I am doing that by serially switching them on and off. I have taken some help from here :

http://www.avr-tutorials.com/projects/atmega16-based-digital-clock

When I start the simulation, it is showing a warning message: Simulation is not running in real time due to excessive CPU load. Also, the digits are flickering. I cannot understand, what should I do so that I get a constant display.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ You can try to simplify the circuit if possible. Can you post your schematic \$\endgroup\$
    – alexan_e
    Jun 11 '15 at 10:28
  • 1
    \$\begingroup\$ That means that the simulation is not running in real time due to excessive CPU load. Sorry, but the error message is quite clear. It'll mean that your PC has problems running the simulation withouth delay. This might indeed cause the flickering of the digits. You should simplify your simulation or get a better CPU to run it with. \$\endgroup\$
    – Paul
    Jun 11 '15 at 11:22
2
\$\begingroup\$

Here's a link to a EDABoard forum thread that explains the error you are experiencing:

Proteus Error" Excess CPU load simulation cannot run in real time"

So it is simply a message from the simulator that it cannot simulate your design in real time and as a consequence it will simulate it at a slower rate. That explains why your display is flickering. On a hardware implementation you would not see that as it would be running real time.

\$\endgroup\$
1
\$\begingroup\$

There are a few tricks to speed a simulation. Set resistors and LEDs to use the digital model. There are simulation options to favour speed over accuracy. As mentioned previously, simplify the design. You could even just simulate the "risky" portion on its own, then build up the rest of the design that only needs non real-time simulation.

\$\endgroup\$
1
  • \$\begingroup\$ Not sure if the recommendation to simplify the design would help, considering it's a seven segment tutorial project. \$\endgroup\$ Dec 12 '16 at 15:11
0
\$\begingroup\$

To get a constant display you have to let the Proteus application run in real time. You can do so by following this steps:

  1. Go to your system Task Manager
  2. Click On "details" at the menu options
  3. Locate or Search for the Proteus software (You can keypress the first letter of the application "P" for quick locating) 4 Right click and goto "set priority", then choose "Real time"

I tried it and it works for me. I hope this will solve your problem.

\$\endgroup\$
1
  • \$\begingroup\$ It is generally not a good idea to set a realtime scheduling priority on arbitrary Windows processes. They will compete with important system processes such as the client-server runtime subsystem host, which runs some of its own threads at elevated priority, and will not help if the system is only lightly loaded to begin with. \$\endgroup\$
    – nanofarad
    May 12 '20 at 17:46
0
\$\begingroup\$

In Proteus Window;

  1. Click "System" and go to "Set Animation Options"
  2. Change Time step per frame and Single Set per frame for your convenience.

This should work

\$\endgroup\$
0
\$\begingroup\$
  1. system >Set animation option; and update all the numbers according to the attached figure.
  2. system >Set simulation option; and update all the numbers according to the attached figure.

Proteus fast simulation settings;Proteus CPU error solved

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Nimesh Jayasena - Hi, (a) I have fixed the syntax so that the > characters don't trigger the blockquote formatting (used when you are quoting from somewhere / someone else). (b) I have removed your contact link. If someone has questions, they can leave a comment below this answer, which will leave a notification in your on-site inbox, and you can configure that to send an email to your registered email address - see your profile settings. You can also add a link (e.g. the same one you added here) to your profile page. \$\endgroup\$
    – SamGibson
    Jun 3 at 16:09
-1
\$\begingroup\$

ISIS is a very large program that requires a lot of RAM and a very fast CPU. If your PC cannot handle the program, it will not be able to run the simulation in real-time and you will get the message you mention. Really the only way to avoid this error altogether is to get a new computer that's a powerhorse (Extremely fast CPU, probably 3+ GHz depending on the complexity of your circuit, tons of Ram). The only thing I can suggest for you right now is to close all other programs except for ISIS. This will take some of the load off of the CPU and you might be able to squeeze out a little more speed from the software, but I can't make any guarantees. Another option would be to overclock your processor, but I really don't recommend this as it can lead to all sorts of other problems, especially if you don't know what you're doing.

\$\endgroup\$
2
  • \$\begingroup\$ Its not the problem of CPU - sorry to say but these is not the correct answer. The problem is in software. My CPU has more than 3GHz procesor, 8 GB RAM and other features. \$\endgroup\$
    – Yash
    Jun 12 '15 at 5:05
  • \$\begingroup\$ Agree, software simulation of hardware is always slower as far as I know. If the software was faster there would be less need to build the hardware ;-) \$\endgroup\$ Jun 12 '15 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.