0
\$\begingroup\$

I am trying to build a custom light setup for my computer desk. I want to use the scroll lock LED signal to control a pair of 12 volt DC CCFL lights run off the same inverter. The problem is when I plug in the CCFL's they just turn on and no matter what I run across the signal pins, they don't turn off.

The SSR I have purchased is from Crydom part number CN048D05. This is a drawing of my circuit:

enter image description here

I am not really an electronics guy, but I have some basic knowledge. The LED circuit that I am trying to use as a control works. I verified that. What am I missing here?

\$\endgroup\$
1
\$\begingroup\$

From the diagram on the SSR (as given in the datasheet), it uses a phototriac. The SSR will not deactivate until the load current drops below the sustain current for the device, which is not given in the datasheet but is usually very close to 0 regardless. This device is not suitable for controlling constant DC loads.

\$\endgroup\$
  • \$\begingroup\$ Ok, thanks. Any suggestions on something I can use? If I need to build my own circuit, that is fine. I am decent with a soldering iron from my keyboard hobby. I just have no clue on how to build where I am getting to. \$\endgroup\$ – Melvang Jun 12 '15 at 16:15
  • \$\begingroup\$ Get one that uses a transistor instead of a thyristor, and is appropriately rated for voltage and current. \$\endgroup\$ – Ignacio Vazquez-Abrams Jun 12 '15 at 16:17
  • 1
    \$\begingroup\$ Although one version of this SSR is specified for AC loads, the one the OP mentions is specified to handle 48 V DC at 0.1 Amp, so it should be able to turn off a DC load. I wonder how much current his CCFLs draw - perhaps he's drawing much more than the rated 0.1 Amp, and has blown the output device of teh SSR. \$\endgroup\$ – Peter Bennett Jun 12 '15 at 16:18
  • \$\begingroup\$ A pulsed DC load, sure. \$\endgroup\$ – Ignacio Vazquez-Abrams Jun 12 '15 at 16:21
  • \$\begingroup\$ @Peter Bennett I measured the CCFLs and it was in the realm of 20 mA. \$\endgroup\$ – Melvang Jun 12 '15 at 16:21
0
\$\begingroup\$

If you disconnect the input pins to the SSR and are sure you have not swapped pins 13 and 14 then the SSR is kauput.

Try measuring the resistance between pins 13 and 14 with all connections off.. if it measures low ohms, that would be a confirmation. If it looks more like a diode (on the meter diode range) then it's probably okay.

100ma is an extremely low maximum current and it's possible that you've fried the output, perhaps merely from charging a capacitor in the inverter (sometimes inverters draw high current whilst they are starting up). Or maybe your 20mA is way low- that does not seem to be enough for a CCFL tube- I would expect some watts.

If the 20mA comes from the rating of the tube, note that the 20mA will be at 600V or something, so the current at 12V will be more like 1.2 or 1.3A, which will surely fry that wimpy SSR.

\$\endgroup\$
  • \$\begingroup\$ The 20mA I measured was on the 12 vdc side of things. The CCFLs I am using are 12" designed for use inside a pc case. The dmm I have is a cheap RS digital one, so I very well could be not seeing a spike when it fires up. The wires for it on the 12 volt side are somewhere in the 26 ga range. I can't imagine they could withstand much power anyway. \$\endgroup\$ – Melvang Jun 12 '15 at 22:02
0
\$\begingroup\$

Thanks for the help guys, but I found my issue. The relay I bought functions fine for this. Apparently, when I was putting it together, I was supplying my load current backwards.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.