9
\$\begingroup\$

I use a 32.768 kHz SMD crystal (datasheet) for a MCU. Here is the layout part of the crystal.

enter image description here

Here is a view from an actual PCB

enter image description here

I mounted the components by hand-soldering, and produced about 30 modules.

Most modules' crystal didn't start working at the beginning, but I solved it by re-soldering the crystal by applying a little bit more solder under it. The interesting thing is that when I touch a pin of the crystal by a tweezers, the crystal starts working. Here is an an oscilloscope view of the crystal's signal.

enter image description here

The glitch is where I touched the path by a tweezers, and then the oscillation starts.

Another fact is that some of board's crystal work if I touch to the C451 cap's path, some of them start working if I touch to C441 cap's path (e.g., if it works by touching the C451 cap's path, it does not work if I touch to C441 cap's path).

This made me doubt if it is related with the solder under the crystal (maybe uneven contact surface or another reason that I can't think of). Or if it is not a purely solder related problem, as I sometimes needed to perform re-soldering process several times till the crystal problem is solved. On the above PCB view, the extra solder sticks out from side of the crystal (no short circuit to another pad or case of the crystal), there should be for sure a connection between the crystal's pin and the PCB pad, but the problem still remains.

Another issue is that I experienced on 4 boards that they work after I re-apply solder under them, but when I test them the next day, the crystal has the same issue.

Question.1 Has anyone experienced similar problem or could think of what could be the actual problem?

Question.2 The boards will be on the field, I have a concern that they will work here but have problem when the customer needs to use them. How I test them is to start the modules couples times at a day and observe if there is any failure and spread this test to a week long. Is there any method/technique to test (or get indication) if the crystal will probably work fine in the near feature

  • I inspected the PCBs by a microscope that there is no short circuit between any trace or there is no any solder connection from the case of the crystal to any path
  • On the problematic boards, I re-placed the crystal with the ones that I removed from the board that works OK, therefore it should not be a component problem
  • I cleaned the flux residues on PCB but it does not change the result
  • I did search if there is a special procedure/technique to solder such type of SMD crystals but couldn't find any related information.

EDIT I tried placing a different capacitor values but didn't help. enter image description here

EDIT2 Here is the gerber view of the reference design of TI, as it is an optional crystal, it is connected through 0 ohm resistors(R451, R441) enter image description here

\$\endgroup\$
  • \$\begingroup\$ How big are C431 and C451, and what is your crystals CL? Note that in the datasheet the CL depends on the exact part number. \$\endgroup\$ – Turbo J Jun 18 '15 at 11:56
  • \$\begingroup\$ Which is the MCU? \$\endgroup\$ – Pedro Quadros Jun 18 '15 at 12:02
  • \$\begingroup\$ the part number of crystal is FC-12M 32.7680KA-A5, the MCU is CC2538 \$\endgroup\$ – Angs Jun 18 '15 at 12:35
  • \$\begingroup\$ Are the picture & photo of the same PCB? The picture made me a bit nervous about ground connection of the left (vertical) load cap, but on the photo I see a big ground plane that is not present on the picture? Doesn't the chip have a ground pin for the oscillator that should be directly connected to the caps, not via a big ground plane that carries other currents? \$\endgroup\$ – Wouter van Ooijen Jun 18 '15 at 12:37
  • \$\begingroup\$ I placed a better screenshot of the board. Thank you for the warning and recommendation about the layout. I placed a screen shot of from the reference design, the return path goes to the ground-plane (under layers don't have a specific path) \$\endgroup\$ – Angs Jun 18 '15 at 12:57
14
\$\begingroup\$

Your layout looks a lot worse in the screen shot than it actually is with the ground pour, however I'd still try to isolate the ground return from the load caps and have it go right back to the ground on the chip. I'd also like to see a ground pour under the caps and crystal (maybe you have one) and connected to the same ground point as the load caps.

That's not likely your problem- there seems like there are several possibilities. First, the metal case of the crystal may be shorting or there is some PCB problem. Your description tends to indicate not.

This is an extremely low power-level crystal (100nW drive 500nW maximum drive). Make sure it's well matched to your chip. You can't change the load capacitances willy-nilly if you want accurate timing (+/- 40ppm is required) but make sure they're appropriate (if there are no caps inside the chip they should generally be a few pF less than double the specified capacitance for the crystal- that datasheet shows several possible values for that crystal). You should test the boards for start-up at temperature extremes- marginal startup at room temperature indicates a probable issue related to gm of the chip, and that changes with temperature.

Finally (and perhaps the best news!), if your assembler is using no-clean flux, and especially if the chip is extreme low power, I'll bet that is exactly your problem. Removing the residue takes a strong solvent and scrubbing. Your re-soldering the parts may affecting the residue and allowing them to start working again.

Edit: I would suspect the no-clean flux residue- it is extremely difficult to remove. You can also compare the load cap values and specs of the Epson crystal you are using to the crystal used in TI's reference design to see if anything jumps out at you. But also scrub the top of that board in the crystal area with some nasty solvent PCB cleaner and a toothbrush. Solvent alone (even something as nasty as lacquer thinner) is not enough.

\$\endgroup\$
  • \$\begingroup\$ Thanks for the valuable comments. I did the assembly by myself, I use no-clean paste(solder as well) as you said but I cleaned the boards by a solvent to get rid off the flux, but didn't solve the problem. \$\endgroup\$ – Angs Jun 18 '15 at 13:00
  • 2
    \$\begingroup\$ I used to clean only PCB but this time cleaned the component as well and it worked. To be sure, I did it to the second board which started to work too. Thanks for the help :) \$\endgroup\$ – Angs Jun 18 '15 at 13:51
  • 1
    \$\begingroup\$ Thanks for the feedback @Angs, it's always good to know when a gnarly problem has been vanquished. \$\endgroup\$ – Spehro Pefhany Jun 18 '15 at 13:53
  • 1
    \$\begingroup\$ Today I had this same problem with a batch of prototype boards. Half of them didn't boot up or took several seconds. Then I scrub them with isopropyl alcohol and they started to work flawlessly. We are still researching why this batch failed while previous ones didn't (we changed crystal brand but also changed solder paste brand, so...). \$\endgroup\$ – MV. Jul 9 '18 at 5:57
8
\$\begingroup\$

You mention that the oscillator starts when you touch it with tweezers. That indicates to me that maybe you need a bit more capacitance on one or maybe both (depends on how this particular oscillator works) of the pins of the crystal. I'm talking about "(3) load capacitance" in the datasheet. Are there any load capacitors connected to this crystal ? If not I'd start with 10 pF, if there is, increase it's value with 10 pF.

I find it hard to believe that it has anythind to do with PCB, in my experience soldering a crystal on a PCB should not be that troublesome. I mostly use hot-air for such small crystals and that almost always works fine.

\$\endgroup\$
  • \$\begingroup\$ I used to test them with different cap values but didn't help neither. (I use hot-hair station as well). You touched a good point that the pins may have a difference capacitances \$\endgroup\$ – Angs Jun 18 '15 at 12:37
  • \$\begingroup\$ Looking at the datasheet, I see that the CC2538 already has 12 pf (typ) load capacitance. Maybe with some external caps this is too much ? I would try to remove the external caps and see what happens. \$\endgroup\$ – Bimpelrekkie Jun 18 '15 at 12:43
  • \$\begingroup\$ I removed the caps, but didn't see any oscillation on the pins. \$\endgroup\$ – Angs Jun 18 '15 at 13:07
  • 1
    \$\begingroup\$ As I see above, it was the flux residue playing tricks on you ! I never expected that could happen, so I learned something, hurray :-) \$\endgroup\$ – Bimpelrekkie Jun 18 '15 at 19:44
1
\$\begingroup\$

Which is the clock this board is supposed to manage?

It seems it's problem with capacitors. When you touch a terminal things work due to your capacitance. Are the values of crystal's capacitor right? Have you tried to re-solder (only re-heat the terminals) the capacitors?

3 terminals crystals may behave more properly, specially for high frequency circuits. You also should want (depending of clock's speed) to match (and reduce to minimum as possible) the lenght of crystal's traces. Always start to route from GND, Vcc and clock.

\$\endgroup\$
  • \$\begingroup\$ This is for a 32 kHz crystal so hardly high frequency. I would only start to worry about matched trace lengths on a PCB above 50 MHz or so. \$\endgroup\$ – Bimpelrekkie Jun 18 '15 at 11:49
  • \$\begingroup\$ Sure. Didn't see the frequency and is definitely "low", forget the second half of the answer. \$\endgroup\$ – Pedro Quadros Jun 18 '15 at 11:51
  • \$\begingroup\$ Also, as your capacitors are really small (maybe 0402 size?) be sure you not short-circuited their terminals while soldering \$\endgroup\$ – Pedro Quadros Jun 18 '15 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.