5
\$\begingroup\$

We have a really weird issue which we just cannot get our head around.

In high level:

We have a unit which contains some electronics, we can access it with 4 cables 2 for power and 2 for communications. The power is 24V DC and communications is RS485. We could not establish communication using a 10m test lead, it has been noticed that when we moved the cable the device functioned sometimes. The conclusion we drew was that the cable was broken somewhere. The cable was cut shorter to around 1m long and worked like a charm.

Fixing:

We tried to use two other long cables as we still needed to be sure that the system works with the required cable length. It did not work.

This is when we started to do some more testing and try to rule out the possible faults:

  • Correct length power and comms cable works fine with test apparatus
  • Short power and comms cable works fine for our actual apparatus
  • Short power and long com works fine for our actual apparatus
  • Long power short comms does not work with out actual apparatus
  • Long power and long comms does not work with our actual apparatus

We have concluded that the issue is with the power cable. The only variable that seems to have an effect is length of the power cable. We have experimented with three different long cables of different qualities, none of which have any effect.

We have one of the electronic components(comms and power as well) as a spare unit which we have tested with the same long cable and it does work. In the unit it self which we are trying to fix we have a power converter (in 18-75V out 24V) which we have no spares for. We have called the manufacturer and asked if they have encountered anything similar but they said they have not.

We have hooked up a multimeter to check the current draw, at short cable we get 0.6A while at long cable we pretty much have nothing.

There is a really small voltage drop at the end of the cable. The power supply we use is 24-28V 15A we have set the power supply to around 25.6V at the end of the cable we had 25.4V.

Currently we cannot access to any electronic as they are in an enclosure, we could open it up but we would like to avoid that if we can solve the issue without it.

In short, how could the length of the power cable effect the current draw from the system, why it would not draw anything when the cable hits a certain length?

Thank you in advance for any ideas you may share to help solve this problem.

\$\endgroup\$
  • 2
    \$\begingroup\$ Have you added a data termination resistor? Have you measured the voltage at the end of the cable when the system stops working? \$\endgroup\$ – Andy aka Jun 19 '15 at 9:13
  • \$\begingroup\$ Sorry, I can't help, but very +1 because of showing own effort to solve. Well written question, thanks! \$\endgroup\$ – Voitcus Jun 19 '15 at 9:16
  • \$\begingroup\$ @Andyaka the voltage is measured it drops down with 0.2V it should not effect anything. No we do not use any data termination resistors. \$\endgroup\$ – Daniel Jun 19 '15 at 9:30
  • \$\begingroup\$ @Voitcus Thank you, did spent whole yesterday trying to find the issue \$\endgroup\$ – Daniel Jun 19 '15 at 9:31
  • \$\begingroup\$ Are you feeding the power cable with a switching power supply? If so, have you tried a linear one? Or just some extra (heavy) capacitance on the output of the supply? Put a scope on the power leads at the supply and load? I have some RS485 and 24VDC runs here around the plant that are more than 1400 feet long, no issues. \$\endgroup\$ – R Drast Jun 19 '15 at 12:38
4
\$\begingroup\$

One issue I have had in a similar situation (An underwater electronics pod on a few tens of meters of cable with power and RS485 control wiring), the fault was due to the voltage drop in the ground connection....

Essentially the IR losses in the supply negative connection (actually the cable screen) were sufficient that the control signals from the head were outside the RS485 common mode range of +12,-7V. Going to an isolated RS485 port at one end fixed it.

One other gotcha with DC/DC bricks like that buck/boost you have is that they sometimes misbehave if the supply is insufficiently stiff on startup, try adding a fairly large electrolytic across the DC/DCs input to stiffen the supply.

\$\endgroup\$
  • \$\begingroup\$ We tried the ground but it does not seems to be enough, we increased the power to 31V no change yet,we will try to get a bit bigger power supply just in case. \$\endgroup\$ – Daniel Jun 19 '15 at 10:54
  • \$\begingroup\$ You are right, it was the power supply. The power supply does not outputs the full voltage at the start so the start voltage is lower than the converter would accept. That means before the power supply reaches the sufficient voltage the power converter shuts down.So even if it gives enough voltage the power converter does not care anymore \$\endgroup\$ – Daniel Jun 19 '15 at 11:30
  • \$\begingroup\$ +1. Perhaps you might add a link from your "gotchas" to "Underestimating Complexity of Power Supply Design". \$\endgroup\$ – davidcary Jun 20 '15 at 12:46
  • \$\begingroup\$ @Daniel: This sounds very close to the problem described at "Latchup of Constant-Power Load With Current-Limited Source". Perhaps you might find one of the solutions on that page useful. \$\endgroup\$ – davidcary Jun 20 '15 at 12:46
  • \$\begingroup\$ Thank you, just reading the pages. There still one question: how could the length of the cable effect the power supply, and why did it work sometimes when we moved the cable(the cable passed continuity test)? \$\endgroup\$ – Daniel Jun 22 '15 at 8:58
2
\$\begingroup\$

No we do not use any data termination resistors

Use data termination resistors. Don't think about it, just do it and come back and let me know if this solved the data issues. Put this right first. Try 120 ohms across the ends of the data cable.

\$\endgroup\$
  • \$\begingroup\$ We have managed to communicate with a test board using the long cable without any issue. We do not think there is any issue with the communication but with the power as we have established that long com short power works. We still could try it but we think it should not make any difference \$\endgroup\$ – Daniel Jun 19 '15 at 10:52
  • 1
    \$\begingroup\$ RS485 drops want to have termination resistors on each end of the cable. Just because it appears to work without them does not mean you can just skip them. Put them in place so that you do not experience later problems when electrical or magnetic coupled disturbance to your long cable causes corruption of your COMMs channel. \$\endgroup\$ – Michael Karas Jun 19 '15 at 13:20
  • \$\begingroup\$ You are right guys, it is not the solution for the problem we have but they should be in place to avoid that issue in the future. \$\endgroup\$ – Daniel Jun 22 '15 at 7:30
1
\$\begingroup\$

I had a similar problem once - a problem that appeared with long cables only (and symptoms changed depending on which long cable was used...) It turned out that the power supply would oscillate (at frequencies in the 10's of MHz) with the long cable which apparently was acting as a large inductive load. These oscillations were picked up by coax cables that ran in the same cable bundle - so we were seeing "noise" in long cables but not always on the same channel! It was initially resolved with an extra 100 nF ceramic across the output of the power supply to get the customer up and running; subsequently the PSU was replaced...

Decoupling was the key.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.