2
\$\begingroup\$

Routing on the top layer is fine. But whenever I try to route on a different layer, it automatically brings me back to the top layer and routes there. Am I missing a step?

Let me make this more clear. 1. I can move from one layer to "next" using the +/- keys and the addition of vias 2. I can add a route segment that is not connected to anything on all layers as well 3. I can "SOMETIMES" add routes directly connecting it to a component, but that doesn't always work (not with all components).

enter image description here

on one of the components for example, I get this pop-out, then it immediately directs me to the top layer.

\$\endgroup\$
  • 1
    \$\begingroup\$ Which layer is active ? At the bottom of the screen, you should see all your layers. Click the layer you want, and then when you route, it will route on that layer. \$\endgroup\$ – efox29 Jun 20 '15 at 6:48
  • \$\begingroup\$ Do you have your layer stack setup for all the routing layers you want? Are you starting out on the layer you want to start routing on but don't actually ahve that layer selected beforehand? (seems obvious, but it still gets me every now & again!). How are you changing layers (keyboard shortcut, or?) Does this happen during interactive-routing when you want to change layers (with +/- keys), or just when you start routing? \$\endgroup\$ – Techydude Jun 20 '15 at 6:51
  • \$\begingroup\$ @efox29 yes I click on the layer tab below before routing on the layer I want but it still brings me back to the top layer. \$\endgroup\$ – Eman alawadhi Jun 20 '15 at 6:58
  • \$\begingroup\$ @Techydude 1. I think so? 2. yes I'm starting in the layer I want to route on by selecting the layer from the tabs below. 3. no, it works just fine when I use the +/- keys because it adds vias. So I can move from one layer to the next, that's fine. However, if I want to start a whole new route on a different layer without having to move from one layer to the next until reaching the desired layer, doesn't work (not for all components I mean). do I have to add vias every time? :s \$\endgroup\$ – Eman alawadhi Jun 20 '15 at 7:08
  • 1
    \$\begingroup\$ If you start a route (i.e. P T) when you're on, for example, the bottom layer, by clicking on a pad that exists only on the top layer, then Altium will change you to the top layer and start your route on that layer. \$\endgroup\$ – Techydude Jun 20 '15 at 7:58
1
\$\begingroup\$

To enable snap to any feature on any layer, especially during interactive routing:

Press D then O (Design, Board Options), then click box next to "Snap On All Layers". This will allow snapping to anything, any layer. Make sure snap Range is not set too large, else routing becomes a nightmare.

Another shortcut is press "Snap" button lower right corner of active pcb layout window (".pcbdoc").

Be careful of what you wish for...

\$\endgroup\$
1
\$\begingroup\$

Had the same problem. Here is the fix:
Go to Rules → Routing Layers, and make sure all routing layers are enabled.
To switch the layers without adding vias, press 'L' while routing instead of +/-.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.