18
\$\begingroup\$

I have a custom schematic and PCB library, and when I try to update my PCB document I get the following error:

Unknown Pin Error

I have checked both the schematic symbol and the PCB footprint about a million times and am certain that I have correctly designated the pins.

Pin mapping

I have learned a little bit about using Altium at university, and I have had some success using custom schematic/PCB libraries in the past but for some reason I just cannot get this one to work. I've done some searching on the forums for this error but have not yet been able to find a solution that worked for me.

This is the schematic:

schematic

Here are the properties of pin 2:

Pin properties

And here is the PCB footprint:

PCB footprint

\$\endgroup\$
7
  • \$\begingroup\$ I suspect that the footprint for SW1 doesn't have a pin 2. Perhaps the pin is named "2", but has some other number. The pin number on the footprint must match the pin number on the schematic symbol. \$\endgroup\$ Jul 8, 2015 at 16:38
  • \$\begingroup\$ Maybe you've failed to update the schematic symbol on the schematic and/or the footprint? The library symbol may be perfect (now) but you've got an older version on the schematic, etc. \$\endgroup\$ Jul 8, 2015 at 17:56
  • \$\begingroup\$ Hi, thank you all for your answers. I have updated the post to hopefully help clarify. I have tried updating the schematic symbol and footprint in Altium, as well as closing down the program and opening it again. I made a new schematic and pcb library with just this one part to see if that would somehow fix the issue but I still keep getting the same error. Obviously I'm doing something wrong, but I just can't see it. \$\endgroup\$ Jul 9, 2015 at 1:25
  • \$\begingroup\$ Did you change the name of the PCB footprint after adding it to the schematic component? If so you'll want to re-add it to your schematic library component if you haven't already. \$\endgroup\$
    – DerStrom8
    Jul 9, 2015 at 1:48
  • \$\begingroup\$ Have you recompiled the libraries (without errors!)? \$\endgroup\$ Jul 9, 2015 at 13:57

14 Answers 14

14
\$\begingroup\$

You probably have edited the the schematic symbol in Sch library after placing its footprint on the layout design.

In situations like this, you need to update your schematic design from library (Tools/Update From Libraries...), then update your PCB with the updated schematic. If problem still there, remove the footprint from PCB file and update the PCB file with schematic again.

Also make sure the symbol in schematic sheet has the same footprint model name as it has in Schematic and PCB libraries.

\$\endgroup\$
2
  • 2
    \$\begingroup\$ This seems like a thorough and reasonable method to ensure it updates. +1 \$\endgroup\$
    – KyranF
    Aug 21, 2015 at 16:17
  • 1
    \$\begingroup\$ I had the same problem, and checked every thing,I updated schematic and all. The solution was update only the footprint (rigth click on component and update PCB with...). \$\endgroup\$
    – user94639
    Dec 16, 2015 at 13:44
5
\$\begingroup\$

To associate pins between schematic documents and footprint documents the pin designators must match. The pins on my schematic were A01, A02, A03, while the pins on the footprint were labeled A1, A2, A3. Changing the schematic to A1, A2, A3, or the foot print to A01, A02, A03, fixed the unknown pin situation.

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Single line answers are subject to downvotes or deletion. Please explain why your solution works, and why the OP's choice is wrong. There is an attempt at some education here... \$\endgroup\$
    – user105652
    Jul 26, 2016 at 1:06
4
\$\begingroup\$

I have the same issue with Altium 14 (14.3.20). The resolution is easy and unintuitive.

Design > Import Changes From [PCB] The dialog is displayed. Click the validate button. The errors are shown. Click the execute button. The errors are cleared. Click the validate button again. The errors remained cleared.

(This scenario is user unfriendly as I expected the validation errors to prevent execute from working.)

\$\endgroup\$
3
\$\begingroup\$

Be aware of pin designators: I had issues with designator "1(C)" which had to be the name, but did accidentally fill in field of designator. Spend lot of time to solve. After renaming those pins to for example "1" I didn't see this errors anymore. I got errors like "unknown pin T1-", while pins that moment has designators like T1-4(C) for example (As you can see, 4(C) wasn't printed in error, which leads me to invalid designator as the reason for this pin-error issue). So: designators should be numbers or letter (0-9, a-z), but not all characters other than that are supported.

To anyone having this issue and came here by google ;)

\$\endgroup\$
2
\$\begingroup\$

I came across this error when creating a part using a custom schematic symbol and footprint. For my situation, I solved the error by changing the schematic symbol type from Mechanical to Standard (No BOM). I believe having a schematic symbol with the type set to Mechanical does not allow the part to link to pins in the PCB layout.

\$\endgroup\$
2
\$\begingroup\$
  1. Delete the component that generated the Unknown Pin from the PCB
  2. Before updating the schematic, right-click on the schematic file and click ‘Compile Document’
  3. Right-click in the Project.PrjPcb and click on the ‘Compile PCB Project’
  4. After these steps, if there is no error, you can update your schematic
  5. If the problem is not resolved, go to ‘Component Links’ from the project menu in PCB and check if all components are in the right window
\$\endgroup\$
1
\$\begingroup\$

Here's another way this can go wrong: Beware of trailing spaces! I spent a fair amount of time scratching my head until I realized the footprint pin was called "1 ", not 1.

You'd expect Altium to trim/ignore trailing spaces but it doesn't.

\$\endgroup\$
1
\$\begingroup\$

Your pin designator on your schematic symbol library should match the pad designator in your PCB library.

Robert Feranec answered this in detail in his Youtube video, Altium - How to Fix: Off Grid Warning, Missing Footprint, Unknown Pin, Clearance Violations at 25:36 (Fixing: Unknown Pin Error).

\$\endgroup\$
0
0
\$\begingroup\$

This error can also be caused by components like ICs being defined with a "mechanical" rather than "standard" type (typically used for items like stand-offs which you want on the BOM but not in the layout). Access this option by right clicking on the schematic component - in the "properties" section there is a "Type" drop down menu.

\$\endgroup\$
0
\$\begingroup\$

It could also be this issue:

For example a resistor.

The resister footprint is not matching with your schematic.

In the schematic, the resistor R1 terminals were named like R1-1 and R1-2.

But, footprint pads name not 1 and 2.

Go to the corresponding library and Edit the footprint pad name.Then it will be Okay!

\$\endgroup\$
0
\$\begingroup\$

Check your pin designator is matching with footprint pin designator, it may contain spaces or unseen characters rename it and update schematics sheets.

\$\endgroup\$
0
\$\begingroup\$

You have to delete PCB file from project re add the PCB as newly then import it will come

\$\endgroup\$
-1
\$\begingroup\$

In my case when clicked Validate Changes button "Unknown Pin" error occurred but when clicked Execute Changes button the error is gone.

\$\endgroup\$
-3
\$\begingroup\$

Check if your pad designator name in pcb foot print and pin designator name of the schematic symbol are same. If the are different change it to the same name so you will get rid of the error.

I had the same error I had a diode with designators "a" and "k" on its pads and designators "1" and "2" in its schematic symbol. So I got the error "unknown connection pin 1 to unknown pin".

\$\endgroup\$
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.